summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 11:47:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 11:51:41 +0200
commitb3663f1f950826cd09e83226b02d3f3c6d421bed (patch)
tree598ca227074c0bd87cf0b1185aa405012d9c05b2
parentmedia-gfx/shotwell: bump to 0.30.10 (diff)
downloadgentoo-b3663f1f950826cd09e83226b02d3f3c6d421bed.tar.gz
gentoo-b3663f1f950826cd09e83226b02d3f3c6d421bed.tar.bz2
gentoo-b3663f1f950826cd09e83226b02d3f3c6d421bed.zip
sci-visualization/fityk: Eradicate python3.6
Closes: https://bugs.gentoo.org/718510 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-visualization/fityk/fityk-1.3.1.ebuild45
1 files changed, 2 insertions, 43 deletions
diff --git a/sci-visualization/fityk/fityk-1.3.1.ebuild b/sci-visualization/fityk/fityk-1.3.1.ebuild
index e67e8dead69c..3900bebeeb70 100644
--- a/sci-visualization/fityk/fityk-1.3.1.ebuild
+++ b/sci-visualization/fityk/fityk-1.3.1.ebuild
@@ -5,9 +5,7 @@ EAPI=6
WX_GTK_VER=3.0
-PYTHON_COMPAT=( python3_6 )
-
-inherit fdo-mime python-r1 wxwidgets
+inherit fdo-mime wxwidgets
DESCRIPTION="General-purpose nonlinear curve fitting and data analysis"
HOMEPAGE="http://fityk.nieto.pl/"
@@ -16,16 +14,13 @@ SRC_URI="https://github.com/wojdyr/${PN}/releases/download/v${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="gnuplot nlopt python readline static-libs wxwidgets"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="gnuplot nlopt readline static-libs wxwidgets"
CDEPEND="
>=dev-lang/lua-5.1:0
dev-libs/boost:=
>=sci-libs/xylib-1
nlopt? ( sci-libs/nlopt )
- python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0= )
wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )"
DEPEND="${CDEPEND}
@@ -37,11 +32,6 @@ pkg_setup() {
use wxwidgets && setup-wxwidgets
}
-src_prepare() {
- default
- use python && python_copy_sources
-}
-
src_configure() {
common_confargs=(
--with-wx-config=wx-config-${WX_GTK_VER}
@@ -54,42 +44,11 @@ src_configure() {
$(use_enable wxwidgets GUI) \
$(use_with readline) \
$(use_enable static-libs static)
-
- if use python; then
- python_configure() {
- econf \
- "${common_confargs[@]}" \
- --enable-python \
- --disable-nlopt \
- --disable-GUI \
- --without-readline
- }
- python_foreach_impl run_in_build_dir python_configure
- fi
-}
-
-src_compile() {
- default
-
- if use python; then
- python_compilation() {
- emake -C fityk swig/_fityk.la
- }
- python_foreach_impl run_in_build_dir python_compilation
- fi
}
src_install() {
default
- if use python; then
- python_installation() {
- emake DESTDIR="${D}" -C fityk install-pyexecLTLIBRARIES
- rm "${D%/}"/$(python_get_sitedir)/*.la || die
- }
- python_foreach_impl run_in_build_dir python_installation
- fi
-
# No .pc file / libfityk.a has dependencies -> need .la file
if ! use static-libs; then
find "${D}" -name '*.la' -delete || die