summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-13 11:50:06 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-13 12:20:52 +0100
commitb38538ccf12f3a2631208e35a75dc74e0a712c21 (patch)
tree2f3e9f7333b1af3844592f24e287d2fcf78e5972
parentvirtual/gsasl: keyword 2 for ~riscv (diff)
downloadgentoo-b38538ccf12f3a2631208e35a75dc74e0a712c21.tar.gz
gentoo-b38538ccf12f3a2631208e35a75dc74e0a712c21.tar.bz2
gentoo-b38538ccf12f3a2631208e35a75dc74e0a712c21.zip
net-proxy/haproxy: migrate to lua-single.eclass
Identical changes in all the ebuilds, tested on 2.2.5-r2 both with and without USE=lua - no problems. Exactly the same logic as before the migration, i.e. only lua5-3 is supported and that is the version that should be used even if any others are present (upstream Makefile only looks for unversioned "lua" if it cannot explicitly find 5.3, at least in the more recent versions anyway). Changing this without revbumps because USE=lua is still masked on this package. Invoking maintainer time-out on this issue. Closes: https://bugs.gentoo.org/752825 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-proxy/haproxy/haproxy-1.8.30-r1.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.0.14-r3.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.0.22-r1.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.0.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.2.14-r1.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.2.5-r2.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.2.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.3.10-r1.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.3.12.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.3.9999.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.4.1-r1.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.4.2.ebuild9
-rw-r--r--net-proxy/haproxy/haproxy-2.4.9999.ebuild9
13 files changed, 91 insertions, 26 deletions
diff --git a/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild b/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild
index 90d010744750..e6b1932baf9b 100644
--- a/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-1.8.30-r1.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.0.14-r3.ebuild b/net-proxy/haproxy/haproxy-2.0.14-r3.ebuild
index 49cfe55e3a3f..68db0dd89896 100644
--- a/net-proxy/haproxy/haproxy-2.0.14-r3.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.14-r3.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.0.22-r1.ebuild b/net-proxy/haproxy/haproxy-2.0.22-r1.ebuild
index 42c17e31be40..6335de9e4750 100644
--- a/net-proxy/haproxy/haproxy-2.0.22-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.22-r1.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.0.9999.ebuild b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
index 0dd6f7085108..41c1558bb74b 100644
--- a/net-proxy/haproxy/haproxy-2.0.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
systemd? ( sys-apps/systemd )
slz? ( dev-libs/libslz:= )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.2.14-r1.ebuild b/net-proxy/haproxy/haproxy-2.2.14-r1.ebuild
index 42c17e31be40..6335de9e4750 100644
--- a/net-proxy/haproxy/haproxy-2.2.14-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.14-r1.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.2.5-r2.ebuild b/net-proxy/haproxy/haproxy-2.2.5-r2.ebuild
index f773d9548c6c..5ef90b045a36 100644
--- a/net-proxy/haproxy/haproxy-2.2.5-r2.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.5-r2.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -67,6 +71,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.2.9999.ebuild b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
index 42c17e31be40..6335de9e4750 100644
--- a/net-proxy/haproxy/haproxy-2.2.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.2.9999.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.3.10-r1.ebuild b/net-proxy/haproxy/haproxy-2.3.10-r1.ebuild
index 143c6394abda..56c62e7ad7df 100644
--- a/net-proxy/haproxy/haproxy-2.3.10-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.3.10-r1.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.3.12.ebuild b/net-proxy/haproxy/haproxy-2.3.12.ebuild
index 143c6394abda..56c62e7ad7df 100644
--- a/net-proxy/haproxy/haproxy-2.3.12.ebuild
+++ b/net-proxy/haproxy/haproxy-2.3.12.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.3.9999.ebuild b/net-proxy/haproxy/haproxy-2.3.9999.ebuild
index 143c6394abda..56c62e7ad7df 100644
--- a/net-proxy/haproxy/haproxy-2.3.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.3.9999.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -44,7 +48,7 @@ DEPEND="
slz? ( dev-libs/libslz:= )
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -66,6 +70,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.4.1-r1.ebuild b/net-proxy/haproxy/haproxy-2.4.1-r1.ebuild
index 31171c86ed5b..9183ede9a103 100644
--- a/net-proxy/haproxy/haproxy-2.4.1-r1.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.1-r1.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -43,7 +47,7 @@ DEPEND="
)
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -61,6 +65,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.4.2.ebuild b/net-proxy/haproxy/haproxy-2.4.2.ebuild
index 31171c86ed5b..9183ede9a103 100644
--- a/net-proxy/haproxy/haproxy-2.4.2.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.2.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -43,7 +47,7 @@ DEPEND="
)
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -61,6 +65,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup
diff --git a/net-proxy/haproxy/haproxy-2.4.9999.ebuild b/net-proxy/haproxy/haproxy-2.4.9999.ebuild
index 31171c86ed5b..9183ede9a103 100644
--- a/net-proxy/haproxy/haproxy-2.4.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.4.9999.ebuild
@@ -3,8 +3,10 @@
EAPI="7"
+LUA_COMPAT=( lua5-3 )
+
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit toolchain-funcs flag-o-matic systemd linux-info ${SCM}
+inherit toolchain-funcs flag-o-matic lua-single systemd linux-info ${SCM}
MY_P="${PN}-${PV/_beta/-dev}"
@@ -25,9 +27,11 @@ ssl systemd +threads tools vim-syntax zlib lua device-atlas 51degrees wurfl"
REQUIRED_USE="pcre-jit? ( pcre )
pcre2-jit? ( pcre2 )
pcre? ( !pcre2 )
+ lua? ( ${LUA_REQUIRED_USE} )
device-atlas? ( pcre )
?? ( slz zlib )"
+BDEPEND="virtual/pkgconfig"
DEPEND="
crypt? ( virtual/libcrypt:= )
pcre? (
@@ -43,7 +47,7 @@ DEPEND="
)
systemd? ( sys-apps/systemd )
zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
+ lua? ( ${LUA_DEPS} )
device-atlas? ( dev-libs/device-atlas-api-c )"
RDEPEND="${DEPEND}
acct-group/haproxy
@@ -61,6 +65,7 @@ haproxy_use() {
}
pkg_setup() {
+ use lua && lua-single_pkg_setup
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup