summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-10 03:12:51 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-10 03:12:51 +0200
commitb526fe18550c9adb8cedb2805e6c9c0bbee5f25e (patch)
tree9788963ad096ce149025a0ed9404eb8d5631e534
parentapp-emulation/docker-runc: Remove old (diff)
downloadgentoo-b526fe18550c9adb8cedb2805e6c9c0bbee5f25e.tar.gz
gentoo-b526fe18550c9adb8cedb2805e6c9c0bbee5f25e.tar.bz2
gentoo-b526fe18550c9adb8cedb2805e6c9c0bbee5f25e.zip
app-emulation/runc: Remove old
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--app-emulation/runc/runc-1.0.0_rc5.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc5.ebuild b/app-emulation/runc/runc-1.0.0_rc5.ebuild
deleted file mode 100644
index 53e421c63abc..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-build golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- RUNC_COMMIT="4fc53a8" # Change this when you update the ebuild
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc64"
- inherit golang-build golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+ambient apparmor hardened +seccomp"
-
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc
-"
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # build up optional flags
- local options=(
- $(usex ambient 'ambient')
- $(usex apparmor 'apparmor')
- $(usex seccomp 'seccomp')
- )
-
- GOPATH="${S}"\
- emake BUILDTAGS="${options[*]}" \
- COMMIT="${RUNC_COMMIT}" -C src/${EGO_PN}
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin runc
- dodoc README.md PRINCIPLES.md
- popd || die
-}