summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:49:05 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:49:05 +0200
commitb54982265bb4168a158d41c77e4ea3b349052983 (patch)
treeaeed00135c8ff85dec805e17dce4fa5fd5202494
parentdev-lang/swi-prolog: bump 7.3 development version (diff)
downloadgentoo-b54982265bb4168a158d41c77e4ea3b349052983.tar.gz
gentoo-b54982265bb4168a158d41c77e4ea3b349052983.tar.bz2
gentoo-b54982265bb4168a158d41c77e4ea3b349052983.zip
dev-libs/wayland-protocols: Version bump
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 03232adae8ce..c733b30c2b24 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1 +1,2 @@
DIST wayland-protocols-1.3.tar.xz 101684 SHA256 6bcd0633fdf9225ef1c7d2831f542e947f7d79811c79fc37f57b2e5375ded82f SHA512 8e407bce93e595ebb7c6a8c7542d4db81d352821c63f41ac75d27f6d52e81e18e0a9a7d4b18460e446c4201931e42a98c0cd214015f154363099eda5747cd738 WHIRLPOOL 73d5c04cb987d0632fe0cc950cd8bf132f9427bd70a65777027148ada2ede0347b336f7faf6e6455171c1a5b2829835edceca15cbbbaf95b99223976279757a9
+DIST wayland-protocols-1.4.tar.xz 102624 SHA256 014a9a23c21ed14f49b1005b3e8efa66d6337d4ceafc97f7b0d6707e7e3df572 SHA512 ffbac79b3be03f7b1c1033923702aadd0bdd2f90dafee946a4a2384eaa9e7f2ab90de6a6497fce374fd3343b133f8dd02683503973a65f947e65b76c47186123 WHIRLPOOL 410923d92e4a962e439f02c5964eb0e61202434bbbf52d68b61549897dcf57040c7b928bad883484802aa3414f63198bba784d644d6c2e8260a78c9247575ac4
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.4.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.4.ebuild
new file mode 100644
index 000000000000..9beb33b1eac8
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}