summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 22:10:41 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:42 +0200
commitb5a558e85c81195af4db66f5c1f1f7591eaf59f3 (patch)
treeecd4caf7b78bdbca70faa23744d951e17dce0644
parentgames-arcade/gnake: Drop old (diff)
downloadgentoo-b5a558e8.tar.gz
gentoo-b5a558e8.tar.bz2
gentoo-b5a558e8.zip
games-arcade/gnujump: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--games-arcade/gnujump/gnujump-1.0.8-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/gnujump/gnujump-1.0.8-r1.ebuild b/games-arcade/gnujump/gnujump-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..271171a2cf0a
--- /dev/null
+++ b/games-arcade/gnujump/gnujump-1.0.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop flag-o-matic
+
+DESCRIPTION="Xjump clone with added features"
+HOMEPAGE="http://gnujump.es.gnu.org"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ virtual/opengl
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ append-libs -lm
+}
+
+src_install() {
+ default
+ einstalldocs
+
+ newicon skins/xjump/hero1.0.png ${PN}.png
+ make_desktop_entry ${PN} "GNUjump"
+}