summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 00:22:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-12 08:07:38 +0100
commitb65514cb8356aa124e564f6b82b0e60c9862c41d (patch)
tree60565a46cf899b3982e16e5c43f0fc31ab1aa0f5
parentdev-util/mdds: Restore KEYWORDS (diff)
downloadgentoo-b65514cb8356aa124e564f6b82b0e60c9862c41d.tar.gz
gentoo-b65514cb8356aa124e564f6b82b0e60c9862c41d.tar.bz2
gentoo-b65514cb8356aa124e564f6b82b0e60c9862c41d.zip
dev-libs/libixion: EAPI-7 bump, python3_7, restore KEYWORDS
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libixion/libixion-0.14.1.ebuild36
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild35
2 files changed, 34 insertions, 37 deletions
diff --git a/dev-libs/libixion/libixion-0.14.1.ebuild b/dev-libs/libixion/libixion-0.14.1.ebuild
index 51e6e3935b81..e962aadc35eb 100644
--- a/dev-libs/libixion/libixion-0.14.1.ebuild
+++ b/dev-libs/libixion/libixion-0.14.1.ebuild
@@ -1,36 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit python-single-r1 ${GITECLASS}
-unset GITECLASS
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
-[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="MIT"
SLOT="0/0.14" # based on SONAME of libixion.so
-[[ ${PV} == 9999 ]] || \
-KEYWORDS=""
-# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="debug python static-libs +threads"
-RDEPEND="
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
dev-libs/boost:=
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
>=dev-util/mdds-1.4.1:1=
+ python? ( ${PYTHON_DEPS} )
"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="${DEPEND}"
pkg_setup() {
use python && python-single-r1_pkg_setup
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 9dbcab360b8f..860c13488fc6 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit python-single-r1 ${GITECLASS}
-unset GITECLASS
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit python-single-r1
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
-[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="MIT"
SLOT="0/0.15" # based on SONAME of libixion.so
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="debug python static-libs +threads"
-RDEPEND="
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
dev-libs/boost:=
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
>=dev-util/mdds-1.4.1:1=
+ python? ( ${PYTHON_DEPS} )
"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="${DEPEND}"
pkg_setup() {
use python && python-single-r1_pkg_setup