summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2018-08-22 23:37:21 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-08 17:10:54 -0700
commitb6579a4044b271eb121d2447f13dff67dc83a105 (patch)
tree9d2cbdeb3a21b9d0bc5739c5dcacaa1c7ee1e1b9
parentdev-lang/execline: Bump to 2.5.0.1 (diff)
downloadgentoo-b6579a4044b271eb121d2447f13dff67dc83a105.tar.gz
gentoo-b6579a4044b271eb121d2447f13dff67dc83a105.tar.bz2
gentoo-b6579a4044b271eb121d2447f13dff67dc83a105.zip
sys-apps/s6: Bump to 2.7.2.1
Bump EAPI to 7, always compile shared libs, fix bug with USE="static -static-libs", simplify dependency syntax. Closes: https://github.com/gentoo/gentoo/pull/9675 Signed-off-by: Luis Ressel <aranea@aixah.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.7.2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index fc86d3003e9f..a44a6564b12d 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -2,3 +2,4 @@ DIST s6-2.1.3.0.tar.gz 181237 BLAKE2B 8cf3b4d4da81aacc17fb663a0648bae1a17085c796
DIST s6-2.6.1.1.tar.gz 196083 BLAKE2B a05083adcba33770ccbc5621c0fc6d7f6c5be22f700bb6a5642fd37bab1ed78b18c16bf5713ade1c2ae456fb653b38aeb793e671138b1038f988ed78c6fad748 SHA512 08f1af0f2e66b3f60f4a6b1489ae91fc59dd5aec97789cc655ae2ba7841327293e3a3027155d02502b34bcdad40778dfaeb441f100e8598aecf081d9d739c99d
DIST s6-2.7.0.0.tar.gz 198303 BLAKE2B e835fd25c75a25d3f39ed59098911e65441e3fcbb4f53c48b3c13de63600975839be4fafb9a620d9ec6168a27a2f0bf86efe08797803230e8e12cab1fb0bcd3a SHA512 495d73b8e5c34ad7295dcf94d34b6998341db063594b31be6b15bead5e47644cc3c7e893974bed4ed1feff7a8a3ad2430658c26eab361e8c90893f877476cc53
DIST s6-2.7.1.1.tar.gz 204738 BLAKE2B 5a322fb992197b921f12fbf1e5bdec7cf1797a2bec81b72faf1eb2bf94c8f46392f9eb494de58d05b6df43daafa5b0abb3947c3c1a0cb5aa3cd83a56ccd45370 SHA512 59b0a611eaa0bbdeae3133a182e933e14806151d3b8d44c7f4258a63693cf2fa487fce91a4ea37527ed0f52f211a5391b3fcf6202773b0a80d6ce7f3de60ff79
+DIST s6-2.7.2.1.tar.gz 207088 BLAKE2B 233413e3cd400af291c20fc1b82e4a803be50eba9854fcbbe917715afe3a9c51467795f620a2596ab067dc7dbb4edcd09177c208bfcaaa7b3b0f392f49c49ff3 SHA512 dcf032b812ce955c2276af36aa93138debcfa9e429e79af7b8da4f1e98b21e7b658564024c713fef45ffee03704d78f7618ad4b890de0bd3defa51b4689d3790
diff --git a/sys-apps/s6/s6-2.7.2.1.ebuild b/sys-apps/s6/s6-2.7.2.1.ebuild
new file mode 100644
index 000000000000..d91e04cfffd3
--- /dev/null
+++ b/sys-apps/s6/s6-2.7.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+DEPEND=">=dev-lang/execline-2.5.0.1[static-libs?]
+ >=dev-libs/skalibs-2.7.0.0[static-libs?]
+"
+RDEPEND=">=dev-lang/execline-2.5.0.1:=
+ !static? ( >=dev-libs/skalibs-2.7.0.0:= )
+"
+
+DOCS="AUTHORS examples README*"
+HTML_DOCS="doc/*"
+
+src_prepare() {
+ default
+
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
+
+ # configure overrides gentoo's -fstack-protector default
+ sed -i "/^tryflag CFLAGS -fno-stack-protector$/d" "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/execline \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ --enable-shared \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc) \
+ $(use_enable static-libs static)
+}