summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 07:42:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:24 +0200
commitb6d49ddfd80f74a866778b9fb012f2821ccbf002 (patch)
tree71db923a3a44038e4a55962f81e05c703b0461b0
parentdev-python/license-expression: Bump to 30.3.1 (diff)
downloadgentoo-b6d49ddfd80f74a866778b9fb012f2821ccbf002.tar.gz
gentoo-b6d49ddfd80f74a866778b9fb012f2821ccbf002.tar.bz2
gentoo-b6d49ddfd80f74a866778b9fb012f2821ccbf002.zip
dev-python/imageio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/files/imageio-2.34.1-numpy-2.patch36
-rw-r--r--dev-python/imageio/imageio-2.34.1-r1.ebuild104
-rw-r--r--dev-python/imageio/imageio-2.34.1.ebuild103
4 files changed, 0 insertions, 244 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 6668c1e25857..df5aeb87a7fd 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,3 +1,2 @@
-DIST imageio-2.34.1.gh.tar.gz 413414 BLAKE2B 59371d0aeace317b9006a0b3b182b97259a53ca0d2288d8ee497234e4f2e7e253c1c27b40b2c5c1f531555a71c7f426ae6d4555043525aa88ca2818d26adfd7d SHA512 d7d1f99f735447e559c0b1fdc2dbe19f2991fb3c640cb9f1396d149c3c44f05e1c357ca8753fff8130625f8fb40a72f277ef09e7cec2b060d1a4f3a675e086a0
DIST imageio-2.34.2.gh.tar.gz 413832 BLAKE2B 1aec3797a5ddf1d644577246e5aab4cde84913aea6befa66d038e1819fac50006fa44bcdac68d46acb0de723b538a88bb7985aa0f855ea62a0403600334a5e43 SHA512 07e5f2fbb46ba653eb3de4f59d4c04d77405e4c7d680a4f853b9b95bc7de48f33866a53f37f56cc8ae0b9e0f505771ab1aa57db9dd975db90077ce8ba0060f9f
DIST imageio-test_images-1121036015c70cdbb3015e5c5ba0aaaf7d3d6021.gh.tar.gz 195497374 BLAKE2B 0083212fd63c196dc2e721bff8f89c177b6741317b6b1c6ae9d00a8dd5fb6366efa3f01b9bffafafac7177cfdaa4d700077a2bad42ada735f5553e97f651c4ad SHA512 1bb1f36a069bfaa0d0ffe5258534e02e49237fc6ce85fe3d3648650130165abc9b3d5ff0e7e5861ee1d94add00d4258575f9c2f8556debecf597bdaa5499efe0
diff --git a/dev-python/imageio/files/imageio-2.34.1-numpy-2.patch b/dev-python/imageio/files/imageio-2.34.1-numpy-2.patch
deleted file mode 100644
index c5c8288da471..000000000000
--- a/dev-python/imageio/files/imageio-2.34.1-numpy-2.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 511ad9b3705fc09d4654d69e42bbafef97bcb0a8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Sebastian=20Wallk=C3=B6tter?= <sebastian@wallkoetter.net>
-Date: Sat, 22 Jun 2024 14:56:11 +0200
-Subject: [PATCH] support numpy 2.0
-
----
- imageio/core/util.py | 2 ++
- imageio/plugins/_dicom.py | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/imageio/core/util.py b/imageio/core/util.py
-index 6b2830421..bfb7e9fe9 100644
---- a/imageio/core/util.py
-+++ b/imageio/core/util.py
-@@ -163,6 +163,8 @@ def __array_wrap__(self, out, context=None):
- return out.dtype.type(out) # Scalar
- elif out.shape != self.shape:
- return out.view(type=np.ndarray)
-+ elif not isinstance(out, Array):
-+ return Array(out, self.meta)
- else:
- return out # Type Array
-
-diff --git a/imageio/plugins/_dicom.py b/imageio/plugins/_dicom.py
-index 96fb6fcde..2f2f7ac51 100644
---- a/imageio/plugins/_dicom.py
-+++ b/imageio/plugins/_dicom.py
-@@ -531,7 +531,7 @@ def _apply_slope_and_offset(self, data):
- data = data.astype(np.float32)
- else:
- # Determine required range
-- minReq, maxReq = data.min(), data.max()
-+ minReq, maxReq = data.min().item(), data.max().item()
- minReq = min([minReq, minReq * slope + offset, maxReq * slope + offset])
- maxReq = max([maxReq, minReq * slope + offset, maxReq * slope + offset])
-
diff --git a/dev-python/imageio/imageio-2.34.1-r1.ebuild b/dev-python/imageio/imageio-2.34.1-r1.ebuild
deleted file mode 100644
index 7b5206ac9e00..000000000000
--- a/dev-python/imageio/imageio-2.34.1-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-TEST_IMAGES_COMMIT=1121036015c70cdbb3015e5c5ba0aaaf7d3d6021
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/test_images/archive/${TEST_IMAGES_COMMIT}.tar.gz
- -> imageio-test_images-${TEST_IMAGES_COMMIT}.gh.tar.gz
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-BDEPEND="
- test? (
- >=dev-python/imageio-ffmpeg-0.4.9-r1[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- || (
- media-video/ffmpeg[openh264]
- media-video/ffmpeg[x264]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}/imageio-2.22.0-block-download.patch"
- # https://github.com/imageio/imageio/pull/1089
- "${FILESDIR}/${P}-numpy-2.patch"
- )
-
- if use test; then
- mv "${WORKDIR}/test_images-${TEST_IMAGES_COMMIT}" .test_images || die
- # upstream tries to update the image cache, and invalidates it
- # if "git pull" fails
- sed -i -e 's:git pull:true:' tests/conftest.py || die
- # ffmpeg tests expect it there
- mkdir -p "${HOME}/.imageio/images" || die
- cp .test_images/cockatoo.mp4 "${HOME}/.imageio/images" || die
- fi
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # uses fsspec to grab prebuilt .so from GitHub, sigh
- tests/test_freeimage.py
- )
-
- local EPYTEST_DESELECT=(
- # Note: upstream has a needs_internet marker but it is also
- # used to mark tests that require test_images checkout that we
- # supply
-
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # Internet
- tests/test_bsdf.py::test_from_url
- tests/test_core.py::test_mvolread_out_of_bytes
- tests/test_core.py::test_request_read_sources
- tests/test_pillow.py::test_gif_first_p_frame
- tests/test_pillow.py::test_png_remote
- tests/test_pillow_legacy.py::test_png_remote
- tests/test_swf.py::test_read_from_url
- # requires pillow-heif, also possibly Internet
- tests/test_pillow.py::test_avif_remote
- tests/test_pillow.py::test_heif_remote
- # not important, requires random system libs
- tests/test_core.py::test_findlib2
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/imageio/imageio-2.34.1.ebuild b/dev-python/imageio/imageio-2.34.1.ebuild
deleted file mode 100644
index 75d05d734168..000000000000
--- a/dev-python/imageio/imageio-2.34.1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-TEST_IMAGES_COMMIT=1121036015c70cdbb3015e5c5ba0aaaf7d3d6021
-DESCRIPTION="Python library for reading and writing image data"
-HOMEPAGE="
- https://imageio.readthedocs.io/en/stable/
- https://github.com/imageio/imageio/
- https://pypi.org/project/imageio/
-"
-SRC_URI="
- https://github.com/imageio/imageio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- test? (
- https://github.com/imageio/test_images/archive/${TEST_IMAGES_COMMIT}.tar.gz
- -> imageio-test_images-${TEST_IMAGES_COMMIT}.gh.tar.gz
- )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- <dev-python/numpy-2[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
- media-libs/freeimage
-"
-BDEPEND="
- test? (
- >=dev-python/imageio-ffmpeg-0.4.9-r1[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/tifffile[${PYTHON_USEDEP}]
- || (
- media-video/ffmpeg[openh264]
- media-video/ffmpeg[x264]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # block silently downloading vulnerable libraries from the Internet
- "${FILESDIR}"/imageio-2.22.0-block-download.patch
- )
-
- if use test; then
- mv "${WORKDIR}/test_images-${TEST_IMAGES_COMMIT}" .test_images || die
- # upstream tries to update the image cache, and invalidates it
- # if "git pull" fails
- sed -i -e 's:git pull:true:' tests/conftest.py || die
- # ffmpeg tests expect it there
- mkdir -p "${HOME}/.imageio/images" || die
- cp .test_images/cockatoo.mp4 "${HOME}/.imageio/images" || die
- fi
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_IGNORE=(
- # uses fsspec to grab prebuilt .so from GitHub, sigh
- tests/test_freeimage.py
- )
-
- local EPYTEST_DESELECT=(
- # Note: upstream has a needs_internet marker but it is also
- # used to mark tests that require test_images checkout that we
- # supply
-
- # Tries to download ffmpeg binary ?!
- tests/test_ffmpeg.py::test_get_exe_installed
- # blocked by our patch
- tests/test_core.py::test_fetching
- tests/test_core.py::test_request
- # Internet
- tests/test_bsdf.py::test_from_url
- tests/test_core.py::test_mvolread_out_of_bytes
- tests/test_core.py::test_request_read_sources
- tests/test_pillow.py::test_gif_first_p_frame
- tests/test_pillow.py::test_png_remote
- tests/test_pillow_legacy.py::test_png_remote
- tests/test_swf.py::test_read_from_url
- # requires pillow-heif, also possibly Internet
- tests/test_pillow.py::test_avif_remote
- tests/test_pillow.py::test_heif_remote
- # not important, requires random system libs
- tests/test_core.py::test_findlib2
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}