summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-12-25 18:22:55 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-12-25 18:23:50 -0600
commitb7b28282696b109de6e1598b41c53f17788aedde (patch)
tree3e9e2ba25061b52d378d66648d7e9e1b74e5fe33
parentsys-cluster/nomad: 1.0.1 bump (diff)
downloadgentoo-b7b28282696b109de6e1598b41c53f17788aedde.tar.gz
gentoo-b7b28282696b109de6e1598b41c53f17788aedde.tar.bz2
gentoo-b7b28282696b109de6e1598b41c53f17788aedde.zip
sys-cluster/nomad: remove old versions
Bug: https://bugs.gentoo.org/760717 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-cluster/nomad/Manifest3
-rw-r--r--sys-cluster/nomad/nomad-0.12.3.ebuild43
-rw-r--r--sys-cluster/nomad/nomad-0.12.4.ebuild43
-rw-r--r--sys-cluster/nomad/nomad-0.12.5.ebuild45
4 files changed, 0 insertions, 134 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index 6cac13f91a5d..0c1fecc7cd79 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1,5 +1,2 @@
-DIST nomad-0.12.3.tar.gz 51432205 BLAKE2B 77090f387e25f226c8d05b6ea16abfac0f4b710a40a3e7e5455bd6c8b7992080980967d4ebb92257348968dddbb45d2e5c3b58f143ae1205742bf08f0dec2a71 SHA512 17d361db11104ddbbae12a17301005c8eca3650e3fdda8f2fd6db8474728f31a2b6f828f2fba7e7d9d132b08cfb070799273353a17f5f66baa4dc5a0492562f8
-DIST nomad-0.12.4.tar.gz 51468076 BLAKE2B 42ca90649263dae6aaa29921853816b6172b285f2675a3fe68aca423bd15213924263433e01d870fa502cfc53372cb6f30f810c7aaadfe63970f91c4bb630912 SHA512 2fb12f96a14772d0a382f40aa686d61823630d49778365447410e7c4a4d7f3cbff275fdeea823f3c397642ce7aeae3618c295d4b08ea884dc51190960f33110e
-DIST nomad-0.12.5.tar.gz 51464001 BLAKE2B 825160a751481972335c4f37ef0514ddeb676a13a210f0faa43d06f1601bb794edf72402b0dfcf96426611e20eb530a5f077b97b331ce07e5fb6b3d3c7598130 SHA512 a3ffff37f3342de041696b1d6e39661d809e5cb82d27d9b2ba67a33a8698eb4afca929679093ec0d23f364a41307e669a6948e58429b97f49ec046d01f8d97f7
DIST nomad-0.12.8.tar.gz 51472616 BLAKE2B 17316e4305edc5a74d640d1bd46e1f997ae43727a6c6dcc5df19af64c659a9b00e4fa2c45c92d70ff70b465278b1bb5c03d81d041facf89549faba17d86efa96 SHA512 c4615043bd1ce3c28cc9a564d58cc0ebbd197b4761763f4d4106fc8d36678c1d8b5b697a38c5ec1093d7d3973b700cd5f32415ec10b8c00546aa1707dea25231
DIST nomad-1.0.1.tar.gz 51101330 BLAKE2B ee955890e7d3cb093c05f91bb4ad4c33f65048875fbf626b8c40975b21c81b8c9802288cc90953a7639ae8b03ba01f1f65320d711bf884aa27c80bfcecccb73b SHA512 07032f965c5826882a4ce0acd7ef2a5d74cc5f0c439b030a4787e60c474070797c5f88d84353e5d423c1d0f6ac411119fd40eebb57848d4eecd8394477fbffa2
diff --git a/sys-cluster/nomad/nomad-0.12.3.ebuild b/sys-cluster/nomad/nomad-0.12.3.ebuild
deleted file mode 100644
index 79ff227381ca..000000000000
--- a/sys-cluster/nomad/nomad-0.12.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-GIT_COMMIT=ef99996f1419334e1d9d23eba9d24e7d9404218f
-
-DESCRIPTION="A simple and flexible workload orchestrator "
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nvidia"
-
-RESTRICT+=" test"
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
- CGO_ENABLED=1 \
- go build \
- -trimpath \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}
diff --git a/sys-cluster/nomad/nomad-0.12.4.ebuild b/sys-cluster/nomad/nomad-0.12.4.ebuild
deleted file mode 100644
index b295320f634c..000000000000
--- a/sys-cluster/nomad/nomad-0.12.4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-GIT_COMMIT=ec7bf9de21bfe3623ff04b009f26aaf488bae2b1
-
-DESCRIPTION="A simple and flexible workload orchestrator "
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nvidia"
-
-RESTRICT+=" test"
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
- CGO_ENABLED=1 \
- go build \
- -trimpath \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}
diff --git a/sys-cluster/nomad/nomad-0.12.5.ebuild b/sys-cluster/nomad/nomad-0.12.5.ebuild
deleted file mode 100644
index 431afd5bbae9..000000000000
--- a/sys-cluster/nomad/nomad-0.12.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-GIT_COMMIT=ec7bf9de21bfe3623ff04b009f26aaf488bae2b1
-
-DESCRIPTION="A simple and flexible workload orchestrator "
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nvidia"
-
-RESTRICT+=" test"
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
- CGO_ENABLED=1 \
- go build \
- -trimpath \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- einstalldocs
-dodoc CHANGELOG.md
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}