summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 11:04:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-25 11:27:09 +0100
commitb845dcfde3984f570d35aa0d45707654e0f09eb8 (patch)
tree148c3ede8f3ecf27b5c8919150710935166e4b0b
parentdev-util/mdds: bump subslot to 2.1 (diff)
downloadgentoo-b845dcfde3984f570d35aa0d45707654e0f09eb8.tar.gz
gentoo-b845dcfde3984f570d35aa0d45707654e0f09eb8.tar.bz2
gentoo-b845dcfde3984f570d35aa0d45707654e0f09eb8.zip
app-text/libetonyek: bump MDDS_VER to 2.1
Bug: https://bugs.gentoo.org/831828 Closes: https://bugs.gentoo.org/866141 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index ff236d229ccd..e45ff9f68680 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -1,15 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-if [[ ${PV} == *9999 ]]; then
+MDDS_VER="2.1"
+
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
inherit autotools git-r3
else
SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
+
DESCRIPTION="Library parsing Apple Keynote presentations"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
@@ -18,12 +21,6 @@ SLOT="0"
IUSE="doc static-libs test"
RESTRICT="!test? ( test )"
-MDDS_VER="2.0"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
RDEPEND="
app-text/liblangtag
dev-libs/librevenge
@@ -37,11 +34,15 @@ DEPEND="${RDEPEND}
sys-devel/libtool
test? ( dev-util/cppunit )
"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == *9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {