summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-10-19 09:36:11 -0400
committerCraig Andrews <candrews@gentoo.org>2021-10-19 09:39:36 -0400
commitb8ae9a98388f884fe8951d4a32ec1704cad31556 (patch)
treefbfd5a427004282a14ef6079c6f87ab2df2ffc5a
parentnet-libs/nghttp2: Removed old (diff)
downloadgentoo-b8ae9a98388f884fe8951d4a32ec1704cad31556.tar.gz
gentoo-b8ae9a98388f884fe8951d4a32ec1704cad31556.tar.bz2
gentoo-b8ae9a98388f884fe8951d4a32ec1704cad31556.zip
mail-client/roundcube: 1.5.0 version bump
Closes: https://bugs.gentoo.org/818853 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.5.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 4f519aef7c5c..de79960d1af8 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,2 +1,3 @@
DIST roundcubemail-1.4.11-complete.tar.gz 7048262 BLAKE2B aaf5e6ce5b07577f687788730bc9181334402bb2ff5e78fb306425913b62b4a8f72505547bdcc8673806b48b9ba8252b8059b59399efc95a51877d5c672a4760 SHA512 2bfe0ff3716f76bf9eb5bf5f7b62c738b233c57e67d6ac767c044d1a3a694ae003642d9cc68a18d6f6ba94135aa7ee1692db920e9127128669faee9ddf78fe80
DIST roundcubemail-1.5-rc-complete.tar.gz 7683911 BLAKE2B e67bbb8ad3d5ffa69091c18b519f78a3dc6d4cc1783921aab9de3c86351d2946cbf784267f5db69434da25413ad1f961161289b47408f14d9e6fa26d8b1e0999 SHA512 4e49e91bb53546e6ac348e33e64019afeee2ce6b78caa4375148fc6fac5abbe8e5db42670c5527e3678abe838ddf349275353e7919584d751bf4c321a62fe795
+DIST roundcubemail-1.5.0-complete.tar.gz 7802014 BLAKE2B d81a521c264b47b55b7f868caf4fd8f0d7fdb2f0d04bf560bf1774c39aa4d0b4143ba1edb977941a4596848921671ec47a0dfd21f20f7e28778a021d58bec402 SHA512 cba32ee2b86864af9d9163d83fa49763267e3420bee59b86d47b889e1bc53871ed2ff5b2c1444778324f4b259e99752faa3b72f909a8f9c26c7af9c96ba08a54
diff --git a/mail-client/roundcube/roundcube-1.5.0.ebuild b/mail-client/roundcube/roundcube-1.5.0.ebuild
new file mode 100644
index 000000000000..e63578dfa2c6
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.5.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.5.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}