summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-18 11:09:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-18 11:09:37 +0100
commitb9c841633df4bf635da79a52106df4785bbb7ddb (patch)
treea82a061122098ef27658b08467d5c0a5459da358
parentdev-python/httplib2: Bump to 0.20.2 (diff)
downloadgentoo-b9c841633df4bf635da79a52106df4785bbb7ddb.tar.gz
gentoo-b9c841633df4bf635da79a52106df4785bbb7ddb.tar.bz2
gentoo-b9c841633df4bf635da79a52106df4785bbb7ddb.zip
kde-frameworks/kio: Fix file copy over FS boundaries w/ Linux <5.3
See also: https://mail.kde.org/pipermail/distributions/2021-November/001096.html Upstream commit aef544ebbb11e842209f3b071eaa9d1c2f26fa40 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch28
-rw-r--r--kde-frameworks/kio/kio-5.88.0-r1.ebuild96
2 files changed, 124 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch b/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch
new file mode 100644
index 000000000000..a6a4877cf0f4
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch
@@ -0,0 +1,28 @@
+From aef544ebbb11e842209f3b071eaa9d1c2f26fa40 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Wed, 17 Nov 2021 23:45:17 +0100
+Subject: [PATCH] Fix copying between different filesystems on Linux < 5.3
+
+From the copy_file_range manpage
+
+EXDEV The files referred to by fd_in and fd_out are not on the same mounted filesystem (pre Linux 5.3).
+---
+ src/ioslaves/file/file_unix.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/ioslaves/file/file_unix.cpp b/src/ioslaves/file/file_unix.cpp
+index b4eca2ae9..02b5dc14c 100644
+--- a/src/ioslaves/file/file_unix.cpp
++++ b/src/ioslaves/file/file_unix.cpp
+@@ -813,7 +813,7 @@ void FileProtocol::copy(const QUrl &srcUrl, const QUrl &destUrl, int _mode, JobF
+ const ssize_t copiedBytes = ::copy_file_range(srcFile.handle(), nullptr, destFile.handle(), nullptr, s_maxIPCSize, 0);
+
+ if (copiedBytes == -1) {
+- if (errno == EINVAL) {
++ if (errno == EINVAL || errno == EXDEV) {
+ break; // will continue with next copy mechanism
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.88.0-r1.ebuild b/kde-frameworks/kio/kio-5.88.0-r1.ebuild
new file mode 100644
index 000000000000..dcc6a8a9819b
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.88.0-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-copy-between-filesystems.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}