summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-09-17 16:12:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-10-12 19:23:30 +0300
commitb9fe2da71ced3a4ec4bbe46b06d371981db99607 (patch)
treedcdb14679e3b469703902057b1af6cb372a3bf4b
parentapp-misc/vcontrold: version bump to 0.98.11 (diff)
downloadgentoo-b9fe2da71ced3a4ec4bbe46b06d371981db99607.tar.gz
gentoo-b9fe2da71ced3a4ec4bbe46b06d371981db99607.tar.bz2
gentoo-b9fe2da71ced3a4ec4bbe46b06d371981db99607.zip
media-libs/assimp: add 5.2.5
Bug: https://github.com/assimp/assimp/pull/4730 Closes: https://bugs.gentoo.org/869461 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/27307 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-libs/assimp/Manifest1
-rw-r--r--media-libs/assimp/assimp-5.2.5.ebuild69
-rw-r--r--media-libs/assimp/files/assimp-5.2.5-fix-version.patch33
3 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/assimp/Manifest b/media-libs/assimp/Manifest
index 34eb32db608e..3810c5ca0704 100644
--- a/media-libs/assimp/Manifest
+++ b/media-libs/assimp/Manifest
@@ -1 +1,2 @@
DIST assimp-5.2.4.tar.gz 49613683 BLAKE2B d99243ce84a76ea237becd0b0982619e8f948ebc75784d8ea35e3800b9ca5084291fa58484433e4f2a7c3cd7ec2869033cf458daf94ee0fc4fe3283592721e73 SHA512 ee988b1806b46c78f97bb5b25237a3f56a7028ed37898fb9b243e379e29e8bfd29e4dffc616566941ed9bdcf502bd30568904ad2ef2ef7d0f63b40daefdc66bf
+DIST assimp-5.2.5.tar.gz 49543936 BLAKE2B 77e0eecd1307646211a86244a371e24401dffd03dceb569acdd63751cdb38bd169c8b12c942efd2e77b5f541653f2775739150b9fe352b8c903dcc4fe7bccca8 SHA512 ac0dc4243f9d1ff077966f0037187b4374075ac97e75e1a3cd6bdc1caf5f8e4d40953d9a8a316480969c09524d87daa9d3ed75e6ac6f037dd5b1c5f25fce3afb
diff --git a/media-libs/assimp/assimp-5.2.5.ebuild b/media-libs/assimp/assimp-5.2.5.ebuild
new file mode 100644
index 000000000000..05540699b679
--- /dev/null
+++ b/media-libs/assimp/assimp-5.2.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Importer library to import assets from 3D files"
+HOMEPAGE="https://github.com/assimp/assimp"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/5.2.5"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="samples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib[minizip]
+ samples? (
+ media-libs/freeglut
+ virtual/opengl
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2.2-disable-failing-tests.patch
+ "${FILESDIR}"/${P}-fix-version.patch
+)
+
+DOCS=( CodeConventions.md Readme.md )
+
+src_prepare() {
+ if use x86 ; then
+ eapply "${FILESDIR}"/${P}-drop-failing-tests-for-abi_x86_32.patch
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DASSIMP_ASAN=OFF
+ -DASSIMP_BUILD_ASSIMP_TOOLS=ON
+ -DASSIMP_BUILD_DOCS=OFF
+ -DASSIMP_BUILD_SAMPLES=$(usex samples)
+ -DASSIMP_BUILD_TESTS=$(usex test)
+ -DASSIMP_BUILD_ZLIB=OFF
+ -DASSIMP_DOUBLE_PRECISION=OFF
+ -DASSIMP_INJECT_DEBUG_POSTFIX=OFF
+ -DASSIMP_IGNORE_GIT_HASH=ON
+ -DASSIMP_UBSAN=OFF
+ -DASSIMP_WARNINGS_AS_ERRORS=OFF
+ )
+
+ if use samples; then
+ mycmakeargs+=( -DOpenGL_GL_PREFERENCE="GLVND" )
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}/bin/unit" || die
+}
diff --git a/media-libs/assimp/files/assimp-5.2.5-fix-version.patch b/media-libs/assimp/files/assimp-5.2.5-fix-version.patch
new file mode 100644
index 000000000000..71b58c4808d1
--- /dev/null
+++ b/media-libs/assimp/files/assimp-5.2.5-fix-version.patch
@@ -0,0 +1,33 @@
+https://github.com/assimp/assimp/pull/4730
+
+From b526d7a4b82be6d8c1481459975350b94384e805 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 17 Sep 2022 15:15:58 +0200
+Subject: [PATCH] fix version
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,7 +56,7 @@ IF(ASSIMP_HUNTER_ENABLED)
+ add_definitions(-DASSIMP_USE_HUNTER)
+ ENDIF()
+
+-PROJECT(Assimp VERSION 5.2.4)
++PROJECT(Assimp VERSION 5.2.5)
+
+ # All supported options ###############################################
+
+--- a/test/unit/utVersion.cpp
++++ b/test/unit/utVersion.cpp
+@@ -61,7 +61,7 @@ TEST_F( utVersion, aiGetVersionMajorTest ) {
+ }
+
+ TEST_F( utVersion, aiGetVersionPatchTest ) {
+- EXPECT_EQ(aiGetVersionPatch(), 4U );
++ EXPECT_EQ(aiGetVersionPatch(), 5U );
+ }
+
+ TEST_F( utVersion, aiGetCompileFlagsTest ) {
+--
+2.37.3
+