summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-22 22:23:39 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-22 22:23:39 +0200
commitbadc897af4f00c73986e601ded2cf51aa3f20a7f (patch)
tree877b0bc70ec543c262560461b666b140865268e8
parentapp-office/libreoffice-l10n: 7.1.5.2 version bump (diff)
downloadgentoo-badc897af4f00c73986e601ded2cf51aa3f20a7f.tar.gz
gentoo-badc897af4f00c73986e601ded2cf51aa3f20a7f.tar.bz2
gentoo-badc897af4f00c73986e601ded2cf51aa3f20a7f.zip
dev-ml/dose3: bump 6.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/dose3/Manifest1
-rw-r--r--dev-ml/dose3/dose3-6.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/dose3/Manifest b/dev-ml/dose3/Manifest
index 13da65b08766..0fc5639da303 100644
--- a/dev-ml/dose3/Manifest
+++ b/dev-ml/dose3/Manifest
@@ -1,3 +1,4 @@
+DIST dose3-6.1.tar.gz 1422879 BLAKE2B b42da3abec4ff9d5d81ea9dbeba0f6acd39fa076c5cb51eb4ae04223ae01078425a7c5d9e80110e7946f8ae87bf7d8c6c124965c3cc47fb1e16473f225dc8adf SHA512 603462645bac190892a816ecb36ef7b9c52f0020f8d7710dc430e2db65122090fdedb24a8d2e03c32bf53a96515f5b51499603b839680d0a7a2146d6e0fb6e34
DIST dose3_5.0.1-16.debian.tar.xz 39448 BLAKE2B a5ae8c74ee1a5a89bf3594cbaf0b37703fcf03a03e336c6b91626fcb6767518c517bf28ec4a24f6cbeb40e1544b34e95855507f39aacca110e8daa6e6e5d3994 SHA512 52d14a45bc0b0a66c4cf3acc05b479b1456c78fa8cb0e453a01dd2f0d849dfcf959bd9e8ff8d505272ad7ad542ff402013746816ead3ccd2dbd0bed572ee2930
DIST dose3_5.0.1.orig.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
DIST dose3_6.0.1-2.debian.tar.xz 23320 BLAKE2B 0351a715756b76c1f81fdf5599d10373ce85554f1d63b4dcbaa647dcf81b099e59c68f93413ca391bdf17b52831b085a7d2b86bc64d86676763bbabd7804a6a4 SHA512 219bb7614d1200adb5d22032cb3d7442c16cdce785088f58b3fcc188856b93817f0157ea6ed1bd72e1f565b9a98df145c188e0fa5d7f538d616b7eccc20ab706
diff --git a/dev-ml/dose3/dose3-6.1.ebuild b/dev-ml/dose3/dose3-6.1.ebuild
new file mode 100644
index 000000000000..ac9e12e891ab
--- /dev/null
+++ b/dev-ml/dose3/dose3-6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="https://gitlab.com/irill/${PN}/-/archive/${PV}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt test"
+
+BDEPEND="
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+RDEPEND="
+ >=dev-lang/ocaml-4.03:=[ocamlopt=]
+ dev-ml/ocaml-base64:=[ocamlopt=]
+ >=dev-ml/cudf-0.7:=[ocamlopt=]
+ >=dev-ml/extlib-1.7.8:=[ocamlopt=]
+ >=dev-ml/ocamlgraph-2.0.0:=[ocamlopt=]
+ >=dev-ml/re-1.2.2:=[ocamlopt=]
+ dev-ml/parmap:=[ocamlopt=]
+ >=dev-ml/camlzip-1.08:=[ocamlopt=]
+ >=dev-ml/camlbz2-0.7.0:=
+ dev-ml/ocaml-expat:=[ocamlopt=]
+ dev-ml/xml-light:=[ocamlopt=]
+ app-arch/rpm
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pyyaml[libyaml] )
+"
+
+# missing test data
+RESTRICT="test"
+
+QA_FLAGS_IGNORED='.*'