summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-04-30 00:38:11 +0200
committerSebastian Pipping <sping@gentoo.org>2021-04-30 02:26:33 +0200
commitbb5efcb600c590d49006f1b5d3593809534ba74e (patch)
tree71463704146c64cdd5f5c031526e8dbd8ec583e4
parentx11-misc/safeeyes: 2.1.3 (diff)
downloadgentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.tar.gz
gentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.tar.bz2
gentoo-bb5efcb600c590d49006f1b5d3593809534ba74e.zip
dev-python/python-dotenv: 0.17.1 + fix tests
Closes: https://bugs.gentoo.org/786579 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.3
-rw-r--r--dev-python/python-dotenv/Manifest1
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.17.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 2f060e473aaf..f05bed51232c 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,3 +1,4 @@
DIST python-dotenv-0.15.0.tar.gz 30008 BLAKE2B 1a406145f0d0497aa037dc95b80fb04854b2889ba4014e4689a24b142d5d71c49d24ac60406f8b2dc873e661c19e36604ef58eb03c7bc9f890f6d4561be199a6 SHA512 f1f16d2688041259027b12920ac5f47c2d1d96cfc3ec8a362a05ddfb13fee2cf4926c20ad38eda521fcafb6eef8d7895d86dedadef1b1ea2ecd7e33734b07cbe
DIST python-dotenv-0.16.0.tar.gz 30903 BLAKE2B 10a737d819bbede558ef87e79b64c4347d05e3dc2bcf76877daf2f3a7afe80230dc95bd2667a7ab6adaad3507d3e55d061b1b43f09f1710778683e79c5aef928 SHA512 8025e3c1e3c2eb5276b13716f3f2f002151c699fa9837d61762fb8bc8b5fe9b58498905ff1689bc62c49612b8d81066e80e0a289164451f5b757bdc6bc0c46eb
DIST python-dotenv-0.17.0.tar.gz 31388 BLAKE2B 1b87a0e1cee4444c6bb929e6f3d859aa032da6105666fd48627987295730e1ffbb233197bdd339996a6ab4259ec313bfa76683c7bbcfc82e39ef02556ff45119 SHA512 77e260c2f39c4f6e7cf030ff2617045a50961d031918e11e1c1711693ab41243de9b14657b3f9e8c76799326af51911da4b034728c5011be7784ebf968f08108
+DIST python-dotenv-0.17.1.tar.gz 31608 BLAKE2B fdddfa1c39282ceec03fc1569d9a7d038e91a046a1248dd27af011dc60361f06f5324504d623a6109d783bb3b5ccac7cae758d918b17f5b0c65a1085bda627ea SHA512 42cdca1356ac2ad80884a5bf3ed419d1202d6a54746f7a21dc9c1bc7579383ac5c72e8b708bc33dfea3904228125fe7b3b2190bfe53e8b4767f5223d59050417
diff --git a/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
new file mode 100644
index 000000000000..400dad458bc2
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.17.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests --install pytest