summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 18:49:56 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:43 +0300
commitbbcc42e573d5278441bb952c99f8f061abd25b0f (patch)
tree1b55ea0af87a6ab62f6c55fde19c618aade0629a
parentlxqt-base/lxqt-globalkeys: add 1.3.0 (diff)
downloadgentoo-bbcc42e573d5278441bb952c99f8f061abd25b0f.tar.gz
gentoo-bbcc42e573d5278441bb952c99f8f061abd25b0f.tar.bz2
gentoo-bbcc42e573d5278441bb952c99f8f061abd25b0f.zip
lxqt-base/lxqt-notification: add 1.3.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index 6ecbab8ef06a..849b06c33b62 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1 +1,2 @@
DIST lxqt-notificationd-1.2.0.tar.xz 60720 BLAKE2B 90d2676e4efd3a46bd6e11becf815c9746bf7ae9f8bb5de5ba48df5af433c91a285f048139cf87a3d1857c2c79ff904e75fdb3b085da80b51e196c07e17e488e SHA512 55ae52cf45942ee7992b099cbea1f81776ab7cc17401f903772458dee3e7ea1899bda13c5e6c5e117b2397dbbbe349c6e06dd389f51b03d4853b2f93c5cb000a
+DIST lxqt-notificationd-1.3.0.tar.xz 61064 BLAKE2B 249a2cd764cb8ca0bbd4de1bb903df87b58d1efe6cab775edc60dfd4ac6da7bac4f83fad95d3567df7fd4adb3a0a06372fbd70b44a71a4e40b03dfdd3a062710 SHA512 8bc57c8a6710aaa5d050802a588530ec446611362eaa7c87aae2dae74b7ed9745486a90efbd854dedf79bc9994e13b5444f8b5259452614e01a8b393dd796607
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild
new file mode 100644
index 000000000000..4f65c2d4b0d3
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.11.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"