summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-29 05:10:50 +0100
committerSam James <sam@gentoo.org>2022-04-29 05:11:31 +0100
commitbbec9c4e706c8bd175da219ba26d35def506c064 (patch)
tree3b4dd9b67a8b905916e797848629dfd89b1772c9
parentkde-frameworks/extra-cmake-modules: Stabilize 5.92.0 ppc, #838502 (diff)
downloadgentoo-bbec9c4e706c8bd175da219ba26d35def506c064.tar.gz
gentoo-bbec9c4e706c8bd175da219ba26d35def506c064.tar.bz2
gentoo-bbec9c4e706c8bd175da219ba26d35def506c064.zip
dev-db/redis: restore partial Lua eclass machinery
It's apparently still needed even if using bundled copy. Closes: https://bugs.gentoo.org/841422 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/redis/redis-6.2.7-r1.ebuild (renamed from dev-db/redis/redis-6.2.7.ebuild)13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-db/redis/redis-6.2.7.ebuild b/dev-db/redis/redis-6.2.7-r1.ebuild
index a40a02c92f80..daabb56d3c64 100644
--- a/dev-db/redis/redis-6.2.7.ebuild
+++ b/dev-db/redis/redis-6.2.7-r1.ebuild
@@ -9,13 +9,14 @@ EAPI=8
# - 5.2 fails with:
# scripting.c:(.text+0x1f9b): undefined reference to `lua_open'
# because lua_open became lua_newstate in 5.2
-#LUA_COMPAT=( lua5-1 luajit )
+LUA_COMPAT=( lua5-1 luajit )
# Upstream have deviated too far from vanilla Lua, adding their own APIs
-# like lua_enablereadonlytable
-inherit autotools flag-o-matic systemd toolchain-funcs tmpfiles
+# like lua_enablereadonlytable, but we still need the eclass and such
+# for bug #841422.
+inherit autotools flag-o-matic systemd toolchain-funcs lua-single tmpfiles
-DESCRIPTION="A persistent caching system, key-value and data structures database"
+DESCRIPTION="A persistent caching system, key-value, and data structures database"
HOMEPAGE="https://redis.io"
SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
@@ -94,11 +95,11 @@ src_prepare() {
# Use the correct pkgconfig name for Lua.
# The upstream configure script handles luajit specially, and is not
- # effected by these changes.
- # -e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${ELUA},g" \
+ # affected by these changes.
sed -i \
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+ -e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${ELUA},g" \
configure.ac || die "Sed failed for configure.ac"
eautoreconf
}