summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-27 18:44:32 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-27 18:44:32 -0500
commitbc0dddc68464b315fdb6a8d313be58e22281efcd (patch)
tree90e02f0138048f56b16f2a927eed6f64c86ac629
parentnet-im/gg-transport: remove gg-transport-2.2.4 (diff)
downloadgentoo-bc0dddc68464b315fdb6a8d313be58e22281efcd.tar.gz
gentoo-bc0dddc68464b315fdb6a8d313be58e22281efcd.tar.bz2
gentoo-bc0dddc68464b315fdb6a8d313be58e22281efcd.zip
net-ftp/tlswrap: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
-rw-r--r--net-ftp/tlswrap/files/tlswrap.init4
-rw-r--r--net-ftp/tlswrap/tlswrap-1.04-r2.ebuild30
2 files changed, 32 insertions, 2 deletions
diff --git a/net-ftp/tlswrap/files/tlswrap.init b/net-ftp/tlswrap/files/tlswrap.init
index fd4eea954af5..7219d8eea130 100644
--- a/net-ftp/tlswrap/files/tlswrap.init
+++ b/net-ftp/tlswrap/files/tlswrap.init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-ftp/tlswrap/tlswrap-1.04-r2.ebuild b/net-ftp/tlswrap/tlswrap-1.04-r2.ebuild
new file mode 100644
index 000000000000..472ed9ee54e6
--- /dev/null
+++ b/net-ftp/tlswrap/tlswrap-1.04-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="a TLS/SSL FTP wrapper/proxy which allows to use TLS with every FTP client"
+HOMEPAGE="http://www.tlswrap.com"
+SRC_URI="http://www.tlswrap.com/${P}.tar.gz"
+
+# GPL-2 for Gentoo init script
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libressl.patch"
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ dodoc ChangeLog README
+ newinitd "${FILESDIR}/tlswrap.init" tlswrap
+}