summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-18 21:30:25 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-18 21:33:07 +0200
commitbc6a56746f95cbba21378bc90305166c7d75480c (patch)
treeedb678a72bc50b271bb95f4ebee49d56fe6428ff
parentdev-util/bdelta: tweak for gcc-6, bug #594246 (diff)
downloadgentoo-bc6a5674.tar.gz
gentoo-bc6a5674.tar.bz2
gentoo-bc6a5674.zip
games-arcade/blobwars: Version bump
Package-Manager: portage-2.3.0
-rw-r--r--games-arcade/blobwars/Manifest1
-rw-r--r--games-arcade/blobwars/blobwars-2.00.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/blobwars/Manifest b/games-arcade/blobwars/Manifest
index 4c62d27a5b11..eebf809dacdf 100644
--- a/games-arcade/blobwars/Manifest
+++ b/games-arcade/blobwars/Manifest
@@ -1 +1,2 @@
DIST blobwars-1.19.tar.gz 67019647 SHA256 f9bafe59ead9e370ceaba4aae3d280241bf05fa06c8ae006eec0322c2fe9e2ed SHA512 d31dcf5aae13bed849f701923cef7e829a43f199b8cde8dc9c28b283c8f7da6c5c8052387fae9add9f1bfb0c857c5be339b6049b6b19ff4c6c5ccbb6233e2643 WHIRLPOOL 4f4a31e80648696ee564be7b4aafddea666dd9cd7239e6310c03f873cb284a59beb40abaa4e8edd3da9e2dbb4dbf9f88cc1db3232b22aeadfda3cad5f473eea4
+DIST blobwars-2.00.tar.gz 66982603 SHA256 c406279f6cdf2aed3c6edb8d8be16efeda0217494acd525f39ee2bd3e77e4a99 SHA512 412afd029554e59e7947466f36b51ef863faf1712898397498d5497e9a38dced92777b7684c1fb231998d893a6ce2c435b8f4278429df41168385de8fa18725b WHIRLPOOL 602a996bb661d8c7f3573220ad2e83e48ef0add898c39a395a2ad8f769fce173f04cb1370fae33e5673485f15d146e7a6b616c3753113b46178e7580b058b0e5
diff --git a/games-arcade/blobwars/blobwars-2.00.ebuild b/games-arcade/blobwars/blobwars-2.00.ebuild
new file mode 100644
index 000000000000..641dd037b507
--- /dev/null
+++ b/games-arcade/blobwars/blobwars-2.00.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2-utils xdg
+
+DESCRIPTION="Platform game about a blob and his quest to rescue MIAs from an alien invader"
+HOMEPAGE="https://sourceforge.net/projects/blobwars/ https://sourceforge.net/apps/mediawiki/blobwars/index.php?title=Main_Page"
+SRC_URI="mirror://sourceforge/blobwars/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-SA-3.0 CC-BY-3.0 GPL-2 LGPL-2.1 fairuse public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ media-libs/sdl2-image
+ media-libs/sdl2-net
+ sys-libs/zlib
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ default
+ sed -i -e "/-Werror/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ RELEASE="1" \
+ USEPAK="1"
+}
+
+src_install() {
+ emake \
+ BINDIR="/usr/bin/" \
+ USEPAK="1" \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ install
+
+ mv -vf \
+ "${D}"/usr/share/doc/${PF}/html/{changes,hacking,porting,readme} \
+ "${D}"/usr/share/doc/${PF}/
+}