summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-02 11:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-02 11:04:57 +0200
commitbd0cac48cd36fca9817b1a4dcab5cf85ae2948fe (patch)
treef74425dc5f2e29486a95bd57abb4484ddac1eb07
parentdev-python/pytest-cache: Recombine impls into a single ebuild (diff)
downloadgentoo-bd0cac48.tar.gz
gentoo-bd0cac48.tar.bz2
gentoo-bd0cac48.zip
dev-python/pytest-pep8: Recombine impls into a single ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild4
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild32
2 files changed, 2 insertions, 34 deletions
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild
index c772b5287435..f531e8650ff7 100644
--- a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r1.ebuild
@@ -3,8 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="pytest plugin to check PEP8 requirements"
@@ -17,7 +18,6 @@ KEYWORDS="amd64 ~arm64 x86"
IUSE=""
RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pep8-1.3[${PYTHON_USEDEP}]
>=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
dev-python/pytest-cache[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild
deleted file mode 100644
index 141399f020e7..000000000000
--- a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check PEP8 requirements"
-HOMEPAGE="https://pypi.org/project/pytest-pep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/1.0.6-MANIFEST.patch
-)
-
-python_test() {
- ${EPYTHON} test_pep8.py || die
-}