summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 06:35:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 07:27:12 +0100
commitbd1a085d7455efdbcfe3a964f450f6b631c9d3d9 (patch)
tree31b4fb0a3a3f26b5f17c67cc404aa04d88bbcef3
parentdev-python/tenacity: Bump to 8.2.0 (diff)
downloadgentoo-bd1a085d7455efdbcfe3a964f450f6b631c9d3d9.tar.gz
gentoo-bd1a085d7455efdbcfe3a964f450f6b631c9d3d9.tar.bz2
gentoo-bd1a085d7455efdbcfe3a964f450f6b631c9d3d9.zip
dev-python/sentry-sdk: Bump to 1.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.15.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 0272564c92ab..ab2df83815c2 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,4 @@
DIST sentry-sdk-1.12.1.gh.tar.gz 306457 BLAKE2B e0c4e92fcf8f0213f27ccf6f03cfbdc66999469357cfdf82e4b923f34d79c44e0824a50caf437dded4404e77cd1cbdede240b1e98bd8408d467b754b3586d598 SHA512 c4fb0d13c1e40e0220ef56c29c2c5235aba0c7be598a545e08af783da0732266455d6b9aa73f2aaa068bf63105369517a12e8abbc7a31410ef3c4bea1a0b3018
DIST sentry-sdk-1.13.0.gh.tar.gz 309851 BLAKE2B e1827bf8aa09a7d28a75f46afbbf3d59d92569e870fec3ad5c960fd566398bacdbd22e3f1c1bdd16f9905d430ddd4c348fb44b8fd2d20b8601bea4b61af1b57e SHA512 6e18fafafe37150958c3a474a7b9e783403fb0dff3747647e438bcfb490f1ba6a9584c9f5a35889c1c8f4e2502d83a2f851d037d11dfc58dd22f04479d3f6ce7
DIST sentry-sdk-1.14.0.gh.tar.gz 312667 BLAKE2B 02772c3313a6cdb5f872df93274b291cdbae35db8387eab3816261b446bb438afd41610580cc642299877d8f03732a1d7bae4e6ad9824a92f4126677a4a3ca1a SHA512 cd0c4ca10d61825919721335fe0413f1050bd8d1f41a2f3f4a25b843c4bf83d35610382f55dc14fe86f70cca962e30a8d9d0708a07b10730783ae09b22f20e04
+DIST sentry-sdk-1.15.0.gh.tar.gz 317804 BLAKE2B 65a45f0da5327057827f4533418d846d8d4dc4bdd2723fddd754e5391e12c50946bb2f3f7914c5ee03cfdac324d565e68158aaca8e6686dc4502a02813cd6442 SHA512 9ae477c3ddc90c4189f4cbcca8756d7b0bd2df0358afa553467b431a2a131f32c9a9df9ce0ca3cca4d98b5a14746222f21476c164bf6da09bc06d94ce7ed0afe
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.15.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.15.0.ebuild
new file mode 100644
index 000000000000..b213e365e768
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.15.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+)