summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-05 05:00:14 +0000
committerSam James <sam@gentoo.org>2020-08-06 19:43:51 +0000
commitbddd492d58c6e7af4937d79b8460a5da3a9f46de (patch)
tree062d95655fdafe8f938fa57de320f27fe1b0d3b0
parentdev-haskell/base-prelude: Fix DESCRIPTION (diff)
downloadgentoo-bddd492d58c6e7af4937d79b8460a5da3a9f46de.tar.gz
gentoo-bddd492d58c6e7af4937d79b8460a5da3a9f46de.tar.bz2
gentoo-bddd492d58c6e7af4937d79b8460a5da3a9f46de.zip
dev-libs/libxslt: drop Python (2.7 only) bindings
Nothing requires libxslt's Python bindings, and they only exist for Python 2.7. Let's drop them instead, after discussion on IRC. Closes: https://bugs.gentoo.org/702346 Closes: https://bugs.gentoo.org/685638 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libxslt/libxslt-1.1.34-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.34-r1.ebuild b/dev-libs/libxslt/libxslt-1.1.34-r1.ebuild
new file mode 100644
index 000000000000..8bc2516fb94d
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.34-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit libtool multilib-minimal toolchain-funcs
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="crypt debug examples static-libs elibc_Darwin"
+
+BDEPEND=">=virtual/pkgconfig-1"
+RDEPEND="
+ >=dev-libs/libxml2-2.9.10:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xslt-config
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libxslt/xsltconfig.h
+)
+
+src_prepare() {
+ default
+
+ DOCS=( AUTHORS ChangeLog FEATURES NEWS README TODO )
+
+ # Prefix always needs elibtoolize if not eautoreconf'd.
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-html-subdir=html \
+ --without-python \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug) \
+ $(use_enable static-libs static) \
+ "$@"
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}