summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-27 03:13:42 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-27 03:16:40 +1200
commitbe43f87f400ab010178cc361c2a8163c0f728aa7 (patch)
tree528f613bc6884d7f3d6dff4f2909d856d9b6fb98
parentpackage.mask: Last rite dev-python/xstatic* (diff)
downloadgentoo-be43f87f400ab010178cc361c2a8163c0f728aa7.tar.gz
gentoo-be43f87f400ab010178cc361c2a8163c0f728aa7.tar.bz2
gentoo-be43f87f400ab010178cc361c2a8163c0f728aa7.zip
dev-perl/YAML-PP: Add missing deps re bug #719642
Test::Deep's absence was breaking tests. Additionally, I've added all the other dependencies upstream mentioned, and moved from DEPEND to BDEPEND for EAPI7 reasons. The "export ... " line is removed because it only affects the building of XS/C code, of which this package has none (otherwise I'd have moved it to src_configure because calling 'export' really shouldn't happen in global scope, especially for this example, which could break pontetial application of per-package settings with package.env) Closes: https://bugs.gentoo.org/719642 Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/YAML-PP/YAML-PP-0.18.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/YAML-PP/YAML-PP-0.18.0-r1.ebuild b/dev-perl/YAML-PP/YAML-PP-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..7db24149237f
--- /dev/null
+++ b/dev-perl/YAML-PP/YAML-PP-0.18.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TINITA
+DIST_VERSION=0.018
+SRC_TEST="do"
+inherit perl-module
+
+DESCRIPTION="YAML 1.2 processor in perl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE='test'
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Exporter
+ virtual/perl-MIME-Base64
+ virtual/perl-Module-Load
+ >=virtual/perl-Scalar-List-Utils-1.70.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Warn
+ )
+"