summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-12-02 22:28:28 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-12-02 22:28:28 +0000
commitbec0bcf1c2424469779f09f33e7d1b12642a2896 (patch)
tree18b88bf27a5cba0d5bf88e7abe3c7217cb50d62b
parentx11-wm/xpra: Adopt package (diff)
downloadgentoo-bec0bcf1c2424469779f09f33e7d1b12642a2896.tar.gz
gentoo-bec0bcf1c2424469779f09f33e7d1b12642a2896.tar.bz2
gentoo-bec0bcf1c2424469779f09f33e7d1b12642a2896.zip
media-video/makemkv: Version bump to 1.14.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-video/makemkv/Manifest2
-rw-r--r--media-video/makemkv/makemkv-1.14.2.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/media-video/makemkv/Manifest b/media-video/makemkv/Manifest
index fa659e307a39..15a7186ed193 100644
--- a/media-video/makemkv/Manifest
+++ b/media-video/makemkv/Manifest
@@ -1,2 +1,4 @@
DIST makemkv-bin-1.14.1.tar.gz 9313691 BLAKE2B cbbb830c20a35d943e8b99bfb05c05942b817b29c986afa441458dfeac5b544caf8256c5ccf361168a3079852cb914e8c2cd4435c37536b9bace1c707bbaa269 SHA512 a3e2f1a41cc430d37d7252e15e5cf04a5c754e1ecb9b4d9e7fd3a3bb6b721d2b4d1d86d55e068d44df0e40912e6bf7a0ebf527b11d2cba07604fc29f5b69943f
+DIST makemkv-bin-1.14.2.tar.gz 9332443 BLAKE2B ef569688aa2134b0549d2474798ca8f50a99eebb42fd45f68502d06fe1334bd9a94abb5f9ca550948db707dd6e7746a9e8e0fdea1a149ab71fb5ae931ffb9a35 SHA512 1c1eb7c5dc7d2db5518823cd2996b427bbe3a38b25e615355d37c75dcda55263b7fbf554abfa7d3e65733707117150cfc408ab678438d868d67afeb9e4021e2d
DIST makemkv-oss-1.14.1.tar.gz 4384005 BLAKE2B 56ec40d46b0d807b552b87e44b129ea982ac5c0cfe4baf4e49a32ebefedd5be9bad8edc69cc5f81a06960e8d6a24ce37fc4f0c914dda32320af3242c3b6fe589 SHA512 4d0bf778d2efd417d058b6db339dc47363b3e179734ec51fc5ebd1fe35d4040aac06ca6387a77362dca8598e8eb5d4db6be16aeea00dc7a3655bf36be26998e5
+DIST makemkv-oss-1.14.2.tar.gz 4384065 BLAKE2B dee07ffc86f95ebbae47d7e56c5b9637462e06e7d75ce93019e7ae7d2845c19b7dee24537bfab38d512e047640803d7df07fd4b3d92ebece553dd3a0c35f16a7 SHA512 cbbe7afa4fcad7e1d21d41badb01c7b4a5a6bb6239d45994d3c405291a0cf651cbd0bbd63ed30884db228457968d17a83ab25dae932a23d3b3aede7ee90437e5
diff --git a/media-video/makemkv/makemkv-1.14.2.ebuild b/media-video/makemkv/makemkv-1.14.2.ebuild
new file mode 100644
index 000000000000..72c2f91d17cd
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.14.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic gnome2-utils linux-info
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping and streaming Blu-ray, HD-DVD and DVD discs"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui libav"
+
+QA_PREBUILT="usr/bin/makemkvcon usr/bin/mmdtsdec"
+
+DEPEND="
+ sys-libs/glibc
+ dev-libs/expat
+ dev-libs/openssl:0=[-bindist(-)]
+ sys-libs/zlib
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ !libav? ( >=media-video/ffmpeg-1.0.0:0= )
+ libav? ( >=media-video/libav-0.8.9:0= )
+"
+RDEPEND="${DEPEND}
+ media-video/ccextractor
+ net-misc/wget"
+
+CONFIG_CHECK="~CHR_DEV_SG"
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-path.patch )
+
+src_configure() {
+ # See bug #439380.
+ replace-flags -O* -Os
+
+ econf \
+ --enable-debug \
+ --disable-noec \
+ --disable-qt4 \
+ $(use_enable gui) \
+ $(use_enable gui qt5)
+}
+
+src_install() {
+ default
+
+ # add missing symlinks for QA
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+
+ cd "${WORKDIR}"/${MY_PB} || die
+
+ # install prebuilt bin
+ dobin bin/$(usex x86 i386 ${ARCH})/makemkvcon
+
+ # install profiles and locales
+ insinto /usr/share/MakeMKV
+ doins src/share/*
+
+ # add symlink rather than relying on MMCCEXTRACTOR env var
+ dosym ccextractor /usr/bin/mmccextr
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "We previously said to copy default.mmcp.xml to ~/.MakeMKV/. This"
+ elog "is no longer necessary and you should delete it from there to"
+ elog "avoid warning messages."
+ elog ""
+ elog "MakeMKV can also act as a drop-in replacement for libaacs and"
+ elog "libbdplus, allowing transparent decryption of a wider range of"
+ elog "titles under players like VLC and mplayer. To enable this, set"
+ elog "the following variables when launching the player:"
+ elog "LIBAACS_PATH=libmmbd LIBBDPLUS_PATH=libmmbd"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}