summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-19 08:06:22 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-19 08:12:21 +0000
commitbf290efb8f4452f2493c881997ff9314120ac016 (patch)
tree92a1737b28674b99223543264a62c193f5bf7379
parentSecurity mask of net-misc/quagga (diff)
downloadgentoo-bf290efb8f4452f2493c881997ff9314120ac016.tar.gz
gentoo-bf290efb8f4452f2493c881997ff9314120ac016.tar.bz2
gentoo-bf290efb8f4452f2493c881997ff9314120ac016.zip
app-misc/rl: EAPI 6 bump.
Package-Manager: portage-2.2.26
-rw-r--r--app-misc/rl/rl-0.2.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/rl/rl-0.2.7-r1.ebuild b/app-misc/rl/rl-0.2.7-r1.ebuild
new file mode 100644
index 000000000000..dfb4d54797af
--- /dev/null
+++ b/app-misc/rl/rl-0.2.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Randomize lines from text files or stdin"
+HOMEPAGE="https://arthurdejong.org/rl"
+SRC_URI="https://arthurdejong.org/rl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE="debug"
+
+multilib_src_configure() {
+ local myeconfargs=()
+ use debug && myeconfargs+=(--enable-debug)
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}