summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-28 09:54:06 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-28 12:00:06 -0500
commitbf5b1cf7cb7c4e3c62b4fcff1ad4818750e010fe (patch)
tree37e4a15d173997aa0896df8a581e76f7195e2356
parentgames-engines/frotz: drop 2.52-r1 (diff)
downloadgentoo-bf5b1cf7cb7c4e3c62b4fcff1ad4818750e010fe.tar.gz
gentoo-bf5b1cf7cb7c4e3c62b4fcff1ad4818750e010fe.tar.bz2
gentoo-bf5b1cf7cb7c4e3c62b4fcff1ad4818750e010fe.zip
games-engines/qtads: drop 3.0.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-engines/qtads/Manifest1
-rw-r--r--games-engines/qtads/files/qtads-3.0-fluidsynth.patch55
-rw-r--r--games-engines/qtads/qtads-3.0.0.ebuild47
3 files changed, 0 insertions, 103 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
index 67994fa5b067..bd461933ea27 100644
--- a/games-engines/qtads/Manifest
+++ b/games-engines/qtads/Manifest
@@ -1,2 +1 @@
-DIST qtads-3.0.0-source.tar.xz 5325048 BLAKE2B cb60908e71edb32157638891a58bed83aba01d484821473716c17845094be9232f9e989bad474db27c1e06734b073ee301756b0528ca880e4c40c0994e95bc48 SHA512 e7b72350876475e0b5b9b8c8c953aa380f5f25dade25785d15c5004a6866bb614c3ca2a3b34f84989013e350f9e73d339ce8ddd7d36766d80a981cfbfda7d1c6
DIST qtads-3.2.0-source.tar.xz 5415396 BLAKE2B 100812db9dd0d0630a5392036e29a366afd61778be2c887e19a1dfafd8f54af00654350fd855691e7e787385675d79a1c065767c93bc97665840396719ae5a0f SHA512 db52ed092d676029cc1ff1d02ddf9e5a91e0bcd77fbfd8e43c923deea4413c452895b70835c519e234f8af0bddf61bad7ad3ec5209876335eacaabe63ed6390a
diff --git a/games-engines/qtads/files/qtads-3.0-fluidsynth.patch b/games-engines/qtads/files/qtads-3.0-fluidsynth.patch
deleted file mode 100644
index 0104d35098dc..000000000000
--- a/games-engines/qtads/files/qtads-3.0-fluidsynth.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From eedae0e7c67da4e12c65ef049665258c1d8f44a8 Mon Sep 17 00:00:00 2001
-From: Michal Petrucha <michal.petrucha@koniiiik.org>
-Date: Thu, 22 Apr 2021 22:55:40 +0200
-Subject: [PATCH] Add support for fluidsynth 2.2.0
-
----
- SDL_audiolib/src/DecoderFluidsynth.cpp | 14 +++++++++++---
- 1 file changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/SDL_audiolib/src/DecoderFluidsynth.cpp b/SDL_audiolib/src/DecoderFluidsynth.cpp
-index 62a99df..0f4760d 100644
---- a/SDL_audiolib/src/DecoderFluidsynth.cpp
-+++ b/SDL_audiolib/src/DecoderFluidsynth.cpp
-@@ -11,6 +11,14 @@
- #include <cstdio>
- #include <fluidsynth.h>
-
-+#if FLUIDSYNTH_VERSION_MAJOR == 2 && FLUIDSYNTH_VERSION_MINOR >= 2
-+using read_cb_count_type = fluid_long_long_t;
-+using seek_cb_offset_type = fluid_long_long_t;
-+#else
-+using read_cb_count_type = int;
-+using seek_cb_offset_type = long;
-+#endif
-+
- namespace chrono = std::chrono;
-
- static fluid_settings_t* settings = nullptr;
-@@ -36,7 +44,7 @@ static void* sfontOpenCb(const char* filename)
- return rwops;
- }
-
--static int sfontReadCb(void* dst, int count, void* rwops)
-+static int sfontReadCb(void* dst, read_cb_count_type count, void* rwops)
- {
- Buffer<char> buf(count);
- if (SDL_RWread(static_cast<SDL_RWops*>(rwops), buf.get(), 1, count) <= 0) {
-@@ -46,7 +54,7 @@ static int sfontReadCb(void* dst, int count, void* rwops)
- return FLUID_OK;
- }
-
--static int sfontSeekCb(void* rwops, long offset, int whence)
-+static int sfontSeekCb(void* rwops, seek_cb_offset_type offset, int whence)
- {
- switch (whence) {
- case SEEK_SET:
-@@ -72,7 +80,7 @@ static int sfontCloseCb(void* rwops)
- return FLUID_OK;
- }
-
--static long sfontTellCb(void* rwops)
-+static seek_cb_offset_type sfontTellCb(void* rwops)
- {
- auto pos = SDL_RWtell(static_cast<SDL_RWops*>(rwops));
- if (pos == -1) {
diff --git a/games-engines/qtads/qtads-3.0.0.ebuild b/games-engines/qtads/qtads-3.0.0.ebuild
deleted file mode 100644
index e375495f938f..000000000000
--- a/games-engines/qtads/qtads-3.0.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit qmake-utils xdg
-
-DESCRIPTION="Multimedia interpreter for TADS text adventures"
-HOMEPAGE="https://realnc.github.io/qtads"
-SRC_URI="https://github.com/realnc/qtads/releases/download/v${PV}/${P}-source.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+sound"
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtwidgets:5
- sound? (
- media-libs/libsdl2[sound]
- media-libs/libsndfile
- media-libs/libvorbis
- media-sound/fluidsynth:0=
- media-sound/mpg123
- )
-"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0-fluidsynth.patch #785235
-)
-
-src_configure() {
- eqmake5 \
- PREFIX="${EPREFIX}/usr" \
- $(usex !sound CONFIG+=disable-audio '') \
- -after CONFIG-=silent
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-}