summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-01-02 11:43:55 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-01-02 11:44:10 -0800
commitbff778c6816bf5b77e986a28d59331d9804fd9b5 (patch)
tree7aae1a25bae90c37ad3242c12fa2b88983068540
parentnet-nds/nsscache: bump. (diff)
downloadgentoo-bff778c6816bf5b77e986a28d59331d9804fd9b5.tar.gz
gentoo-bff778c6816bf5b77e986a28d59331d9804fd9b5.tar.bz2
gentoo-bff778c6816bf5b77e986a28d59331d9804fd9b5.zip
net-nds/nsscache: upstream codebase is dumb and unconditionally needs bsddb even when nssdb is not used.
Package-Manager: portage-2.2.24
-rw-r--r--net-nds/nsscache/nsscache-0.23-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-nds/nsscache/nsscache-0.23-r2.ebuild b/net-nds/nsscache/nsscache-0.23-r2.ebuild
new file mode 100644
index 000000000000..77d5e07063ca
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.23-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="https://github.com/google/nsscache"
+SRC_URI="https://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="nssdb nsscache"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/python-ldap[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/bsddb3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+
+src_prepare() {
+ find "${S}" -name '*.py' -exec \
+ sed -i '/^import bsddb$/s,bsddb,bsddb3 as bsddb,g' \
+ {} \+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+
+ keepdir /var/lib/nsscache
+}