summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-08-01 23:17:54 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-08-01 23:20:05 -0400
commitc0957dc25d73e5097e08fbc419dda9f685496741 (patch)
tree415b13775f5c9fe5f9b235f8ad60d802d85a6824
parentwww-client/firefox: arm64 stable (bug #690626) (diff)
downloadgentoo-c0957dc25d73e5097e08fbc419dda9f685496741.tar.gz
gentoo-c0957dc25d73e5097e08fbc419dda9f685496741.tar.bz2
gentoo-c0957dc25d73e5097e08fbc419dda9f685496741.zip
sys-process/gnome-usage: new ebuild
A nice way to view information about use of system resources, like memory and disk space. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
-rw-r--r--sys-process/gnome-usage/Manifest1
-rw-r--r--sys-process/gnome-usage/gnome-usage-3.32.0.ebuild47
-rw-r--r--sys-process/gnome-usage/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/gnome-usage/Manifest b/sys-process/gnome-usage/Manifest
new file mode 100644
index 000000000000..9f3060cec6d8
--- /dev/null
+++ b/sys-process/gnome-usage/Manifest
@@ -0,0 +1 @@
+DIST gnome-usage-3.32.0.tar.xz 352372 BLAKE2B 0d26f0cad96f2621acbc4b1eda08f5cadfc1ca0086b631f99027987e4af0b36bb5eefbdb0dfa34f35c1b5bd56f4a1457f5fb3f635206769955c6cfb40dbe64dc SHA512 c1ed3ab8fcdb039bc05f4b091a7ac8c032b7f7847f77bff79c89a57d5c0075f712228c752674e0c61f63a1adaea911304de5a1cdd1c342c74abea6e48defee88
diff --git a/sys-process/gnome-usage/gnome-usage-3.32.0.ebuild b/sys-process/gnome-usage/gnome-usage-3.32.0.ebuild
new file mode 100644
index 000000000000..f03682112efe
--- /dev/null
+++ b/sys-process/gnome-usage/gnome-usage-3.32.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A nice way to view information about use of system resources."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-usage"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=x11-libs/gtk+-3.20.10:3
+ >=gnome-base/libgtop-2.34.0:2
+ >=dev-libs/libdazzle-3.30
+"
+
+DEPEND="${RDEPEND}
+ ${vala_depend}
+ >=sys-devel/gettext-0.19.8
+"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/sys-process/gnome-usage/metadata.xml b/sys-process/gnome-usage/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/sys-process/gnome-usage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>