summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 19:50:08 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 21:45:14 -0500
commitc0acac88cd33c628836fbe7465e858a5407179fe (patch)
tree8ebcf7cd42558e440da85f9510bc0b833a9c7a97
parentmate-extra/mate-polkit: Fix long description (diff)
downloadgentoo-c0acac88cd33c628836fbe7465e858a5407179fe.tar.gz
gentoo-c0acac88cd33c628836fbe7465e858a5407179fe.tar.bz2
gentoo-c0acac88cd33c628836fbe7465e858a5407179fe.zip
x11-wm/marco: Import 1.10.x from Project:MATE repo
Package-Manager: portage-2.2.26
-rw-r--r--x11-wm/marco/Manifest1
-rw-r--r--x11-wm/marco/marco-1.10.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-wm/marco/Manifest b/x11-wm/marco/Manifest
index 617713125e18..591ccca7527d 100644
--- a/x11-wm/marco/Manifest
+++ b/x11-wm/marco/Manifest
@@ -1,2 +1,3 @@
+DIST marco-1.10.3.tar.xz 1119064 SHA256 a07cfcc16d744a7c840011802e16a006a0770aaf84f63a4247b791bb31cb4f36 SHA512 8bb3a3a1af15f07e092fb3e8d6dd7a61d65cdb78525ad4e39f07feda04cd37f5f81b8c142ca09a7a929a39eb84e16b9e61ee26cbae0f4c147750430052e4e878 WHIRLPOOL 12099a938694ddc2e1daa47912df71cbbdc00e38bbb4dfbdf0748750eb6de65f7bbc9d493730253cfafb76b1ff51e9b2fde2545b040c948016acdffd665a5830
DIST marco-1.8.0.tar.xz 1111780 SHA256 b66f58c87552a20a4533c1ea482d374a35c8921091736e198c2bf1774163a9e6 SHA512 ae6619547b7ebcb27d3baee9612d91a74da99cc7d001d7659a4452855d6c722d4c3bee465ea194e579e61660ce9089d158e4308c78b025ce2848e88e53794023 WHIRLPOOL e33b7a2024c41cbf9c27b0cd1d0423daf17a60d15b2a05c59d66353a9b6349e8c5bcd289e222e4ba24678442a8b9bc7d2fbe3fb0f245767aa615402f4b029ae6
DIST marco-1.8.2.tar.xz 1119448 SHA256 a5ef03dfd4de035ed6c99aca500256c6f4564a090702066303770dbf7c893443 SHA512 9d8ea38e78a07cd94737bd1da7956b09fba8adc7716b63b281300cdf7c43db1fbed285b6f6085b41bf8ff367e48993ecd230e1ce8a29f3c476d5247274087959 WHIRLPOOL 53ae69ddd5146b6d1342f9ff70d3d5f587befbef25d90d70ae4a2327d3f3b62cb6255ff8840ea88b8d74b8b4b50062a801219dff6b9b6df676726749e4d38027
diff --git a/x11-wm/marco/marco-1.10.3.ebuild b/x11-wm/marco/marco-1.10.3.ebuild
new file mode 100644
index 000000000000..5ab15307b18e
--- /dev/null
+++ b/x11-wm/marco/marco-1.10.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Debug only changes CFLAGS
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE default window manager"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="startup-notification test xinerama"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.32.10:2
+ >=gnome-base/libgtop-2:2=
+ gnome-extra/zenity:0
+ media-libs/libcanberra:0[gtk]
+ x11-libs/cairo:0
+ >=x11-libs/pango-1.2:0[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libXcomposite-0.2:0
+ x11-libs/libXcursor:0
+ x11-libs/libXdamage:0
+ x11-libs/libXext:0
+ x11-libs/libXfixes:0
+ x11-libs/libXrandr:0
+ x11-libs/libXrender:0
+ >=x11-libs/startup-notification-0.7:0
+ virtual/libintl:0
+ xinerama? ( x11-libs/libXinerama:0 )
+ !!x11-wm/mate-window-manager"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.34.90:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ x11-proto/xextproto:0
+ x11-proto/xproto:0
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto:0 )"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ --with-gtk=2.0 \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"