summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafaelmartins@gentoo.org>2018-04-20 17:45:02 +0200
committerRafael G. Martins <rafaelmartins@gentoo.org>2018-04-20 17:45:02 +0200
commitc12e6b78971234b48f0daecb3be3fc3d98e5f83f (patch)
treeef8bca08799896898488f96a256ec7ceb2168c13
parentapp-cdr/cdrtools: amd64 stable wrt bug #653608 (diff)
downloadgentoo-c12e6b78971234b48f0daecb3be3fc3d98e5f83f.tar.gz
gentoo-c12e6b78971234b48f0daecb3be3fc3d98e5f83f.tar.bz2
gentoo-c12e6b78971234b48f0daecb3be3fc3d98e5f83f.zip
www-servers/gunicorn: version bump (bug #653590)
also removed examples use flag, banned on EAPI 6 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-19.7.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index e4ea77d20cf1..99327531e528 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -2,3 +2,4 @@ DIST gunicorn-19.1.1.tar.gz 385155 BLAKE2B 683bff89e9f7037b22748c968f842cbd6328f
DIST gunicorn-19.3.0.tar.gz 395381 BLAKE2B cbdf0e4a8c5f107b3dbee9ac30b141142bd10e5a4d9046de3c2fe3af965e6b5f091ff29bdfd9f4a1da75ea409e6f9a3b9627f6069d5529dc9db4d6ad1e3f9860 SHA512 8c4e0bb1bf0b35aaf9160b9b7d87890a991451fbc86186454203f3483767858944704c1ec22dd52480ce1e4693e84b62b1428dd3b67b2ae925e0475dc08fcb50
DIST gunicorn-19.4.5.tar.gz 399066 BLAKE2B 046dd95170b3d6c6071c955462af5777ee0fbaa48d80c4a16b78fb1c9abd49bef98f7428e7f861b404a2791683074ae37a22a7e73d5b7f183fa6ac77d139123e SHA512 a255178a4ce7966af5883fc6c104e7c472c87ce91861caf976b52cfb0ccd90b34109130334afa6c1f6dd251a4b33b052b1f9a4f598c5cd1e7f26e332b92e9154
DIST gunicorn-19.6.0.tar.gz 404497 BLAKE2B 8edc6907daf9cced83ab4213146d468789a23b4428a562f9f5cc7d2aa8f7c57137ca9f163609b6a8955537dfc5a93910a7cef183fa6457c5017cbb3941f4e0c8 SHA512 50b69ae18acc6f60be6fc5c6f4a867d8415d32009a1f959155b58502d52403a057612e97d6c9b69ec068ee5af7b9b045952a636a5edf4713a1249492611be479
+DIST gunicorn-19.7.1.tar.gz 402658 BLAKE2B 8fd96ae3cc8c78beae8f3f84f960d75dc1a17134050fa7735cf0f01bd2a560bca733450d98c69e7c77b9679b3502df8e71dfe29d4127bd0f5086b7961b35e756 SHA512 ee01276028ad65c72076f09d95b6801a720700ec55d9b0bf929e0a6c0db546178a21c34f584ef1780f329218b2cfa3dc1e0c2d81bd4f7fcb0b328fbdfb0b9f0e
diff --git a/www-servers/gunicorn/gunicorn-19.7.1.ebuild b/www-servers/gunicorn/gunicorn-19.7.1.ebuild
new file mode 100644
index 000000000000..8aef7da541fa
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+DOCS="README.rst"
+
+python_prepare_all() {
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}