summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-04-24 22:04:43 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-04-24 22:05:42 +0200
commitc15caab8983407dc394a3871207109572a97fd03 (patch)
tree94c896bddce4fd361dfa6b0c6714db5d4498a320
parentnet-im/telegram-desktop: drop old (diff)
downloadgentoo-c15caab8983407dc394a3871207109572a97fd03.tar.gz
gentoo-c15caab8983407dc394a3871207109572a97fd03.tar.bz2
gentoo-c15caab8983407dc394a3871207109572a97fd03.zip
media-plugins/vdr-xineliboutput: version bump, cleanup old
thx to S. Schreier for reporting this Closes: https://bugs.gentoo.org/717070 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--media-plugins/vdr-xineliboutput/Manifest2
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0.ebuild (renamed from media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0.ebuild)19
2 files changed, 13 insertions, 8 deletions
diff --git a/media-plugins/vdr-xineliboutput/Manifest b/media-plugins/vdr-xineliboutput/Manifest
index 023e8ba28089..b3eae169dc54 100644
--- a/media-plugins/vdr-xineliboutput/Manifest
+++ b/media-plugins/vdr-xineliboutput/Manifest
@@ -1,2 +1,2 @@
-DIST vdr-xineliboutput-2.0.0.tgz 413085 BLAKE2B 85fffdbea51917035475863019095ed81bdda6e8e994c3d76b83433fca14cf680c64e268c04316199f6b707b5da7bf0ceafb991781ced552abebebf2e283fb5f SHA512 9410072bcd8ae71196e3417c12dc810da109f155748d58b3b0b422cd6d8cd29b3f8a7d0cbffada9dd22af679161ffeb096e952f620ed1c7f1122b46bf111f9ee
DIST vdr-xineliboutput-2.1.0.tgz 415333 BLAKE2B 8311271dda889cde5ab69d5bf1f643c8f6b1991ca615ce6322ea5585aac12b07b32f6fd933bf6c3797d45971597e61d429e4d9de356246109cab7c8f059b4d79 SHA512 226654dcd47864e9df8282ef401509d291677587b2850872c535abb7bee468a7c6d72c30953090890d002f0977aa1ee357a0fe6938ce3f3c1b6324e82b926537
+DIST vdr-xineliboutput-2.2.0.tgz 426058 BLAKE2B 8a5e325e0dd45dffdbcf1b9e49d4ae2486d3b3c7585dbca81855264a0a9057c48da7626acd5e9d7b2113b200eead178b19a0d9834ace5d25cd97157912d50bfa SHA512 d3b753fe496c6f73d491195cc1dac3333a46f2ef6350683fc15e3e8a423a90946574c3fdf0ed43727d61f007a8abdf3041e274317216bf06a8146dc9206f88d9
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0.ebuild
index da8c3780dcae..a0ae0f345cf4 100644
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0.ebuild
+++ b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs vdr-plugin-2
@@ -14,11 +14,11 @@ SRC_URI="mirror://sourceforge/${PN#vdr-}/${P}.tgz"
SLOT="0"
LICENSE="GPL-2+"
KEYWORDS="~amd64 ~x86"
-IUSE="bluray caps dbus fbcon jpeg libextractor nls opengl +vdr vdpau +X +xine xinerama"
+IUSE="bluray caps cec dbus fbcon jpeg libextractor nls opengl +vdr vaapi vdpau +X +xine xinerama"
COMMON_DEPEND="
vdr? (
- >=media-video/vdr-1.6.0
+ media-video/vdr
libextractor? ( >=media-libs/libextractor-0.5.20 )
caps? ( sys-libs/libcap )
)
@@ -31,12 +31,13 @@ COMMON_DEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
- xinerama? ( x11-libs/libXinerama )
+ bluray? ( media-libs/libbluray )
dbus? ( dev-libs/dbus-glib dev-libs/glib:2 )
- vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2 )
jpeg? ( virtual/jpeg:* )
- bluray? ( media-libs/libbluray )
opengl? ( virtual/opengl )
+ vaapi? ( x11-libs/libva >=media-libs/xine-lib-1.2[vaapi] )
+ vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2[vdpau] )
+ xinerama? ( x11-libs/libXinerama )
)
)"
@@ -82,21 +83,25 @@ src_configure() {
$(use_enable X xshm) \
$(use_enable X xdpms) \
$(use_enable X xshape) \
+ $(use_enable X xrandr) \
$(use_enable X xrender) \
$(use_enable fbcon fb) \
$(use_enable vdr) \
$(use_enable xine libxine) \
$(use_enable libextractor) \
$(use_enable caps libcap) \
+ $(use_enable cec libcec) \
$(use_enable jpeg libjpeg) \
$(use_enable xinerama) \
- $(use_enable vdpau) \
$(use_enable dbus dbus-glib-1) \
$(use_enable nls i18n) \
$(use_enable bluray libbluray) \
$(use_enable opengl) \
${myconf} \
|| die
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
}
src_install() {