summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-23 09:28:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-23 09:33:42 -0500
commitc1b0c6d2e86fcba4c9f198d3945c17f5d96dcc92 (patch)
treee91dc50586e4ef8f111559f28113aa8e6609c96a
parentapp-misc/ddcutil: fix build with USE=-usb-monitor (again) (diff)
downloadgentoo-c1b0c6d2e86fcba4c9f198d3945c17f5d96dcc92.tar.gz
gentoo-c1b0c6d2e86fcba4c9f198d3945c17f5d96dcc92.tar.bz2
gentoo-c1b0c6d2e86fcba4c9f198d3945c17f5d96dcc92.zip
Revert "dev-qt/qtbase: add IUSE=cpu_flags_x86_rdrand"
Regardless of if that worked or not, on second thought this was a bad idea. The flag is rather misleading for generic binhosts because they should actually *enable* it to allow optional usage (runtime detection). And then, this is actually broken on top, so let's just return to the previous state. This reverts commit c198f69e66547b5ba7d2ba1b9bae576ce93ee703. Bug: https://bugs.gentoo.org/922498 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtbase/qtbase-6.6.1-r3.ebuild11
-rw-r--r--dev-qt/qtbase/qtbase-6.6.9999.ebuild11
-rw-r--r--dev-qt/qtbase/qtbase-6.7.9999.ebuild11
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild11
4 files changed, 4 insertions, 40 deletions
diff --git a/dev-qt/qtbase/qtbase-6.6.1-r3.ebuild b/dev-qt/qtbase/qtbase-6.6.1-r3.ebuild
index d9f21bee7611..a0defb2de975 100644
--- a/dev-qt/qtbase/qtbase-6.6.1-r3.ebuild
+++ b/dev-qt/qtbase/qtbase-6.6.1-r3.ebuild
@@ -25,8 +25,6 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [cpuflags]="cpu_flags_x86_rdrand"
-
[optfeature]="nls wayland" #810802,864509
)
IUSE="${QT6_IUSE[*]}"
@@ -237,14 +235,7 @@ src_configure() {
)
if use amd64 || use x86; then
- # see bug #922498, let detection do its thing if set
- use cpu_flags_x86_rdrand ||
- mycmakeargs+=(
- -DQT_FEATURE_rdrnd=OFF
- -DQT_FEATURE_rdseed=OFF
- )
-
- # see bug #913400 for explanations, mostly to handle -mno-*
+ # see bug #913400 for explanations
local cpufeats=(
# list of checked cpu features in configure.cmake
avx avx2 avx512{bw,cd,dq,er,f,ifma,pf,vbmi,vbmi2,vl}
diff --git a/dev-qt/qtbase/qtbase-6.6.9999.ebuild b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
index 1df2ecec87b6..dcaf37200a90 100644
--- a/dev-qt/qtbase/qtbase-6.6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
@@ -24,8 +24,6 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [cpuflags]="cpu_flags_x86_rdrand"
-
[optfeature]="nls wayland" #810802,864509
)
IUSE="${QT6_IUSE[*]}"
@@ -234,14 +232,7 @@ src_configure() {
)
if use amd64 || use x86; then
- # see bug #922498, let detection do its thing if set
- use cpu_flags_x86_rdrand ||
- mycmakeargs+=(
- -DQT_FEATURE_rdrnd=OFF
- -DQT_FEATURE_rdseed=OFF
- )
-
- # see bug #913400 for explanations, mostly to handle -mno-*
+ # see bug #913400 for explanations
local cpufeats=(
# list of checked cpu features in configure.cmake
avx avx2 avx512{bw,cd,dq,er,f,ifma,pf,vbmi,vbmi2,vl}
diff --git a/dev-qt/qtbase/qtbase-6.7.9999.ebuild b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
index 558e1b6b1caf..10afd1ff2ad0 100644
--- a/dev-qt/qtbase/qtbase-6.7.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
@@ -24,8 +24,6 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [cpuflags]="cpu_flags_x86_rdrand"
-
[optfeature]="nls" #810802
)
IUSE="${QT6_IUSE[*]}"
@@ -237,14 +235,7 @@ src_configure() {
)
if use amd64 || use x86; then
- # see bug #922498, let detection do its thing if set
- use cpu_flags_x86_rdrand ||
- mycmakeargs+=(
- -DQT_FEATURE_rdrnd=OFF
- -DQT_FEATURE_rdseed=OFF
- )
-
- # see bug #913400 for explanations, mostly to handle -mno-*
+ # see bug #913400 for explanations
local cpufeats=(
# list of checked cpu features in configure.cmake
avx avx2 avx512{bw,cd,dq,er,f,ifma,pf,vbmi,vbmi2,vl}
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 558e1b6b1caf..10afd1ff2ad0 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -24,8 +24,6 @@ declare -A QT6_IUSE=(
[sql]="mysql oci8 odbc postgres +sqlite"
[widgets]="cups gtk"
- [cpuflags]="cpu_flags_x86_rdrand"
-
[optfeature]="nls" #810802
)
IUSE="${QT6_IUSE[*]}"
@@ -237,14 +235,7 @@ src_configure() {
)
if use amd64 || use x86; then
- # see bug #922498, let detection do its thing if set
- use cpu_flags_x86_rdrand ||
- mycmakeargs+=(
- -DQT_FEATURE_rdrnd=OFF
- -DQT_FEATURE_rdseed=OFF
- )
-
- # see bug #913400 for explanations, mostly to handle -mno-*
+ # see bug #913400 for explanations
local cpufeats=(
# list of checked cpu features in configure.cmake
avx avx2 avx512{bw,cd,dq,er,f,ifma,pf,vbmi,vbmi2,vl}