summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-21 21:11:05 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-21 21:17:32 -0700
commitc1e8bce7fc198e6606b2ee9fad249cfb3d2a0ff8 (patch)
tree6c7d476aa1aad891c0aa64284dfa4e5f443284e9
parentnet-vpn/vpncloud: new version imported, 2.3.0 (diff)
downloadgentoo-c1e8bce7fc198e6606b2ee9fad249cfb3d2a0ff8.tar.gz
gentoo-c1e8bce7fc198e6606b2ee9fad249cfb3d2a0ff8.tar.bz2
gentoo-c1e8bce7fc198e6606b2ee9fad249cfb3d2a0ff8.zip
app-accessibility/at-spi2-core: Version bump to 2.44.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.44.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index a01b16f04f6f..870221f601b4 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.42.0.tar.xz 198016 BLAKE2B 9b14d7d0f5845c7510f7b256a05f5e30c3d3d893a9ae63eee81b3d378dfa9f6ebaa9853f60b23734929692efc4b8c652d4bd7bd035bd989fe0006975bdbea427 SHA512 befcab94b3aa99471723238d9666fc6667041b058a2bac3b012cfa15a91950996431296f33c921764e0ec4ffd0cc41ebe00be461a8460d6f4d2bafff19a38e10
DIST at-spi2-core-2.44.0.tar.xz 209692 BLAKE2B 149251ba4061f5dbfac1e27775491bb6d7cee279cb7bd58c05f97cdec8a4e0208e5a129651a07c9febea681cc3fe36a7d7fa57c43c2b558249cdd321466729dd SHA512 6d74a56d7ad6c643985e98aebbbf0cdaad69c03b8030f8968bd9cce9357805cd846d71d35d2cc4a193770cd6d4a83cbfb98ef082e17719f3dee7b839c48bda44
+DIST at-spi2-core-2.44.1.tar.xz 209780 BLAKE2B e76f0b0c478564181db774633dfc9613bdfa6c74c5c52878d877723e37605b7b7169fee45a9025b331e84bf5af8132eed50b388db9ac1aee0fec7776a633628a SHA512 8d85df75f886c4a19d829d14e5a9412b607b9cbe2d1b7ecb95b4082602f0624e90747fe955f96d378c3a52bc0e732074b97008bb34e6acc2722c7056b2c0504e
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.44.1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.44.1.ebuild
new file mode 100644
index 000000000000..6d1568dc223b
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.44.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+REQUIRED_USE="gtk-doc? ( X )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.62:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ -Dintrospection=$(multilib_native_usex introspection)
+ -Dx11=$(usex X)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}