summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-10-12 16:50:22 -0700
committerZac Medico <zmedico@gentoo.org>2022-10-12 16:55:29 -0700
commitc2101479695abb32c889bd73f678da0b9cb58e65 (patch)
tree823cfb5a19d041740c925774df37c98c015a92d1
parentnet-misc/electrum-ltc: add 4.2.2.1 (diff)
downloadgentoo-c2101479695abb32c889bd73f678da0b9cb58e65.tar.gz
gentoo-c2101479695abb32c889bd73f678da0b9cb58e65.tar.bz2
gentoo-c2101479695abb32c889bd73f678da0b9cb58e65.zip
net-misc/electrum-ltc: drop 4.0.9.1
Closes: https://bugs.gentoo.org/869506 Closes: https://bugs.gentoo.org/695090 Closes: https://bugs.gentoo.org/792219 Closes: https://bugs.gentoo.org/809272 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--net-misc/electrum-ltc/Manifest1
-rw-r--r--net-misc/electrum-ltc/electrum-ltc-4.0.9.1.ebuild143
-rw-r--r--profiles/package.mask6
3 files changed, 0 insertions, 150 deletions
diff --git a/net-misc/electrum-ltc/Manifest b/net-misc/electrum-ltc/Manifest
index cdbb25b95e9..37e653f60e6 100644
--- a/net-misc/electrum-ltc/Manifest
+++ b/net-misc/electrum-ltc/Manifest
@@ -1,2 +1 @@
-DIST electrum-ltc-4.0.9.1.tar.gz 4464915 BLAKE2B 2c328f9fc433f39b11aa2bfc4e397b75aadd07adc66576ae985c5b41b32d663df80bb67dafbbce210f3581f6fb43e666070d090bf189eb4907efd07d306fc945 SHA512 926ad16246d0609a787614b84cadfa893ed792ab2a54a3c0b9d707019e29874b1ae1c42dba098f34b61f915d85578809ff87dc9026c85563264a2d2b583c8823
DIST electrum-ltc-4.2.2.1.tar.gz 5109859 BLAKE2B b3327f6bcf23b5caca6196e380e62f154a9f56a5b636a8d0cc49e08ed0ab5a05b4b1a81d9869b92125526339924ccb9b555a704eb7fa98bce59eac6088c7ebfe SHA512 1ac44a29cd0db7de9570e339892ff42bd72abbe3eeb9f8106eda7be67dbb492cc830881d52f915ffde776892d461f9cff1b88a9ee20bf3c64139c407118e4eb9
diff --git a/net-misc/electrum-ltc/electrum-ltc-4.0.9.1.ebuild b/net-misc/electrum-ltc/electrum-ltc-4.0.9.1.ebuild
deleted file mode 100644
index 89fa018a611..00000000000
--- a/net-misc/electrum-ltc/electrum-ltc-4.0.9.1.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_8 )
-PYTHON_REQ_USE="ncurses?"
-
-inherit desktop distutils-r1 xdg
-
-EGIT_COMMIT="${PV}"
-DESCRIPTION="Litecoin thin client"
-HOMEPAGE="https://electrum-ltc.org/"
-SRC_URI="https://github.com/pooler/electrum-ltc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="audio_modem cli cosign digitalbitbox email ncurses qrcode +qt5 sync vkb
- l10n_es l10n_ja l10n_pt-BR l10n_pt-PT l10n_zh-CN"
-
-REQUIRED_USE="
- || ( cli ncurses qt5 )
- audio_modem? ( qt5 )
- cosign? ( qt5 )
- digitalbitbox? ( qt5 )
- email? ( qt5 )
- qrcode? ( qt5 )
- sync? ( qt5 )
- vkb? ( qt5 )
-"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/aiohttp-socks[${PYTHON_USEDEP}]
- =dev-python/aiorpcX-0.19*[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/jsonrpclib[${PYTHON_USEDEP}]
- dev-python/pbkdf2[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- qrcode? ( media-gfx/zbar[v4l] )
- qt5? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
- )
- ncurses? ( dev-lang/python )
-"
-
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-
-DOCS="RELEASE-NOTES"
-
-src_prepare() {
- eapply "${FILESDIR}/3.1.2-no-user-root.patch"
- eapply "${FILESDIR}/3.2.3-pip-optional-pkgs.patch"
- eapply "${FILESDIR}/3.3.2-desktop.patch"
-
- # unbind aiorpcX dep
- sed -e '/aiorpcx/s:,<0.19::' \
- -i contrib/requirements/requirements.txt || die
-
- # Prevent icon from being installed in the wrong location
- sed -i '/icons_dirname/d' setup.py || die
-
- if ! use qt5; then
- sed "/'electrum_ltc.gui.qt',/d" -i setup.py || die
- fi
-
- local wordlist=
- for wordlist in \
- $(usex l10n_ja '' japanese) \
- $(usex l10n_pt-BR '' $(usex l10n_pt-PT '' portuguese)) \
- $(usex l10n_es '' spanish) \
- $(usex l10n_zh-CN '' chinese_simplified) \
- ; do
- rm -f "${PN}/wordlist/${wordlist}.txt" || die
- sed -i "/${wordlist}\\.txt/d" ${PN/-/_}/mnemonic.py || die
- done
-
- # Remove unrequested GUI implementations:
- local gui setup_py_gui
- for gui in \
- $(usex cli '' stdio) \
- kivy \
- $(usex qt5 '' qt ) \
- $(usex ncurses '' text ) \
- ; do
- rm ${PN/-/_}/gui/"${gui}"* -r || die
- done
-
- # And install requested ones...
- for gui in \
- $(usex qt5 qt '') \
- ; do
- setup_py_gui="${setup_py_gui}'electrum_gui.${gui}',"
- done
-
- sed -i "s/'electrum_gui\\.qt',/${setup_py_gui}/" setup.py || die
-
- local bestgui
- if use qt5; then
- bestgui=qt
- elif use ncurses; then
- bestgui=text
- else
- bestgui=stdio
- fi
- sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN/-/_}/${PN} || die
-
- local plugin
- # trezor requires python trezorlib module
- # keepkey requires trezor
- for plugin in \
- $(usex audio_modem '' audio_modem ) \
- $(usex cosign '' cosigner_pool ) \
- $(usex digitalbitbox '' digitalbitbox ) \
- $(usex email '' email_requests ) \
- ledger \
- keepkey \
- $(usex sync '' labels ) \
- trezor \
- $(usex vkb '' virtualkeyboard ) \
- ; do
- rm -r ${PN/-/_}/plugins/"${plugin}"* || die
- sed -i "/${plugin}/d" setup.py || die
- done
-
- eapply_user
-
- xdg_environment_reset
- distutils-r1_src_prepare
-}
-
-src_install() {
- doicon -s 128 ${PN/-/_}/gui/icons/${PN}.png
- distutils-r1_src_install
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 7af9c5f34e8..5922276a2de 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -282,12 +282,6 @@ net-nds/nsscache
dev-python/python-etcd
# Arthur Zamarin <arthurzam@gentoo.org> (2022-09-10)
-# Python 3.8 only package, with capped old dependencies, and open
-# bugs and issues.
-# Removal: 2022-10-10. Bugs #869506, #695090, #792219, #809272.
-net-misc/electrum-ltc
-
-# Arthur Zamarin <arthurzam@gentoo.org> (2022-09-10)
# Upstream repository archived. Python 3.8 only, with issues for
# newer targets. No reverse dependencies in tree.
# Removal: 2022-10-10. Bugs #869503, #747997, #832242.