summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-12 15:32:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-12 17:06:30 +0100
commitc35768f45238c3e072741cba85302c9be4d8deac (patch)
treef99841080e5e9c2992033419214ac27e2ccad02c
parentRevert "dev-util/cppcheck: Maintain" (diff)
downloadgentoo-c35768f45238c3e072741cba85302c9be4d8deac.tar.gz
gentoo-c35768f45238c3e072741cba85302c9be4d8deac.tar.bz2
gentoo-c35768f45238c3e072741cba85302c9be4d8deac.zip
dev-python/setuptools: Bump to 40.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-40.6.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 25b6e9ce4a4e..8adbf039027b 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -5,3 +5,4 @@ DIST setuptools-38.5.1.zip 737995 BLAKE2B 9772d39928c6633ca529292d646c1c8e96a5a7
DIST setuptools-38.6.1.zip 738985 BLAKE2B 73e5258b9fe2587b5662e80267e59bbc23484815d997a808c83e030e2dffa9a499fa1bed7e9e127cf3b92cb09451e70e590dd2e71135941124fe9d3383f7dc24 SHA512 38685b97a7c4cdfb67846f910afce5faf60ef1519ccb70acdfd2da83ddbfe1a56b5b03e0b8ce5dbc80dcec14847f716d7b23777e2be0ea7e6afd6da3b645b3ef
DIST setuptools-40.0.0.zip 849857 BLAKE2B 6ce687904e0c6ef6cd55557ce848583e1645b6c5cfa80b005b25c20e52fc6985be673f2a77a9f79a3a5effc8e581492429bbf73074525827f539a411c6751373 SHA512 c90d136831af822a7f42bbd7eca4c1f4dd73d14f87182aa1251e70610db877b26bcda8fd0a10f5db0fcd84f9098a35b79a130b3142ade9d0081a538778ae53b7
DIST setuptools-40.6.2.zip 839184 BLAKE2B bc17aeaf7710742b70735f4bd0df2f4d8546eebaae000270b21ce605c83966998a2f51658d243838286f3101d7497c761535a9ffed003ae5e00c81bca8b70ad9 SHA512 3f1aa20e905deb22dda366f479f87cd772238d07e869fdc4f65a7926373414a77b7ddbfd78fd9825154409b3c01d787830354d206a45cdfca879bf35d3b83e03
+DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31d670bddb9e4ea058b8ee7dffbe6fcb0e5fd24baf3fb38f5e824fde36aa8dc1e09d7ac37f9375ee351406389cd6 SHA512 6c628b8fc67645bca96ddcd016ec9a685e91690bf98dff077e842cfbd0d8d24de76ac51b3ff238d31551a48819d8f694fee6e9bb422ca954e54c22b4bda0038c
diff --git a/dev-python/setuptools/setuptools-40.6.3.ebuild b/dev-python/setuptools/setuptools-40.6.3.ebuild
new file mode 100644
index 000000000000..0f231c9d846b
--- /dev/null
+++ b/dev-python/setuptools/setuptools-40.6.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}