summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2018-07-16 11:03:59 +0200
committerHanno <hanno@gentoo.org>2018-07-16 11:03:59 +0200
commitc38e9c07638d7db84e8e98b3e999cefaf50745db (patch)
tree27841bedd624f1555f32f9405fa085fb9c2652cf
parentprofiles: Last rite gnome-base/libgnomeprint* (diff)
downloadgentoo-c38e9c07638d7db84e8e98b3e999cefaf50745db.tar.gz
gentoo-c38e9c07638d7db84e8e98b3e999cefaf50745db.tar.bz2
gentoo-c38e9c07638d7db84e8e98b3e999cefaf50745db.zip
dev-php/pecl-gnupg: Allow gnupg 2.
The existing package is not installable due to conflicting dependencies. Basic functionality works with gnupg 2. Some tests fail, therefore restricting tests. Closes: https://bugs.gentoo.org/657048 Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
new file mode 100644
index 00000000000..d4642afe226
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+S="${PHP_EXT_S}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme app-crypt/gnupg"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/1.3.2/01-large_file_system.patch )
+
+# tests are broken with gnupg 2.0/2.1, see:
+# https://github.com/php-gnupg/php-gnupg/issues/2
+# https://github.com/php-gnupg/php-gnupg/issues/3
+RESTRICT="test"