summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:44 -0400
commitc3ac246f05ba2342207b66cd1ce56140015db6d7 (patch)
treef2e7e0c022d46805e396bdc905aada5a6f90d7c7
parentx11-apps/xlogo: Make XORG_CONFIGURE_OPTIONS an array (diff)
downloadgentoo-c3ac246f05ba2342207b66cd1ce56140015db6d7.tar.gz
gentoo-c3ac246f05ba2342207b66cd1ce56140015db6d7.tar.bz2
gentoo-c3ac246f05ba2342207b66cd1ce56140015db6d7.zip
x11-base/xorg-server: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xorg-server/xorg-server-1.20.11.ebuild36
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild36
2 files changed, 40 insertions, 32 deletions
diff --git a/x11-base/xorg-server/xorg-server-1.20.11.ebuild b/x11-base/xorg-server/xorg-server-1.20.11.ebuild
index 241f73b55e23..609ab534563e 100644
--- a/x11-base/xorg-server/xorg-server-1.20.11.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.20.11.ebuild
@@ -132,13 +132,15 @@ pkg_setup() {
ewarn "Performance may be unacceptable without it."
ewarn "Build with USE=-minimal to enable glamor."
fi
+}
+src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
# NOTE: fop is used for doc generating; and I have no idea if Gentoo
# package it somewhere
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable debug)
$(use_enable dmx)
@@ -178,17 +180,28 @@ pkg_setup() {
if use systemd || use elogind; then
XORG_CONFIGURE_OPTIONS+=(
- "--enable-systemd-logind"
- "--disable-install-setuid"
- "$(use_enable suid suid-wrapper)"
+ --enable-systemd-logind
+ --disable-install-setuid
+ $(use_enable suid suid-wrapper)
)
else
XORG_CONFIGURE_OPTIONS+=(
- "--disable-systemd-logind"
- "--disable-suid-wrapper"
- "$(use_enable suid install-setuid)"
+ --disable-systemd-logind
+ --disable-suid-wrapper
+ $(use_enable suid install-setuid)
)
fi
+
+ xorg-3_src_configure
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
}
src_install() {
@@ -214,12 +227,3 @@ pkg_postrm() {
rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
fi
}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index c6ec9c9033a1..1b2a33ee9084 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -133,13 +133,15 @@ pkg_setup() {
ewarn "Performance may be unacceptable without it."
ewarn "Build with USE=-minimal to enable glamor."
fi
+}
+src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
# NOTE: fop is used for doc generating; and I have no idea if Gentoo
# package it somewhere
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable debug)
$(use_enable dmx)
@@ -178,17 +180,28 @@ pkg_setup() {
if use systemd || use elogind; then
XORG_CONFIGURE_OPTIONS+=(
- "--enable-systemd-logind"
- "--disable-install-setuid"
- "$(use_enable suid suid-wrapper)"
+ --enable-systemd-logind
+ --disable-install-setuid
+ $(use_enable suid suid-wrapper)
)
else
XORG_CONFIGURE_OPTIONS+=(
- "--disable-systemd-logind"
- "--disable-suid-wrapper"
- "$(use_enable suid install-setuid)"
+ --disable-systemd-logind
+ --disable-suid-wrapper
+ $(use_enable suid install-setuid)
)
fi
+
+ xorg-3_src_configure
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
}
src_install() {
@@ -214,12 +227,3 @@ pkg_postrm() {
rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
fi
}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}