summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-02-20 10:48:45 +0100
committerSam James <sam@gentoo.org>2022-02-20 23:08:52 +0000
commitc3ec8e1563acdc7509d0889be2b027d12a7de9fc (patch)
treeba4d8a4cb4b076f273942bed4e954758582881be
parentdev-libs/libusb: fix build failure with -O3 (diff)
downloadgentoo-c3ec8e1563acdc7509d0889be2b027d12a7de9fc.tar.gz
gentoo-c3ec8e1563acdc7509d0889be2b027d12a7de9fc.tar.bz2
gentoo-c3ec8e1563acdc7509d0889be2b027d12a7de9fc.zip
sci-libs/pdal: add pdal library
to work with point clouds (i.e. in qgis) Bug: https://bugs.gentoo.org/830003 Bug: https://github.com/gentoo/gentoo/pull/23526 Closes: https://bugs.gentoo.org/830002 Closes: https://github.com/gentoo/gentoo/pull/23525 Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/pdal/Manifest1
-rw-r--r--sci-libs/pdal/files/pdal-2.3.0-fix_cmake_install_location.patch17
-rw-r--r--sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch77
-rw-r--r--sci-libs/pdal/metadata.xml19
-rw-r--r--sci-libs/pdal/pdal-2.3.0.ebuild48
5 files changed, 162 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
new file mode 100644
index 000000000000..87d5e450ed54
--- /dev/null
+++ b/sci-libs/pdal/Manifest
@@ -0,0 +1 @@
+DIST PDAL-2.3.0-src.tar.gz 110530128 BLAKE2B 435997e7ae7fe84ff77d8546e68ce6d32e54a221b5a4bbea45543554355506d7900f65ebb47a4f5333d0f3a44192ffe548178b6b3e8b3b7575d3c104618e288b SHA512 9de87de7370175e76b95d3ec08667eb28b90a63eed8133f144427ff931e575d1f37aa13496f12054577539ee552458475dd054bcbdedfabe52eb0e32c4483d05
diff --git a/sci-libs/pdal/files/pdal-2.3.0-fix_cmake_install_location.patch b/sci-libs/pdal/files/pdal-2.3.0-fix_cmake_install_location.patch
new file mode 100644
index 000000000000..65e32100d18d
--- /dev/null
+++ b/sci-libs/pdal/files/pdal-2.3.0-fix_cmake_install_location.patch
@@ -0,0 +1,17 @@
+--- a/cmake/config.cmake.orig 2022-02-19 13:06:41.654048306 +0100
++++ b/cmake/config.cmake 2022-02-19 13:07:21.007165692 +0100
+@@ -6,7 +6,7 @@
+ configure_package_config_file(
+ PDALConfig.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/PDALConfig.cmake
+- INSTALL_DESTINATION ${LIB_INSTALL_DIR}/cmake/PDAL
++ INSTALL_DESTINATION ${PDAL_LIB_INSTALL_DIR}/cmake/PDAL
+ PATH_VARS INCLUDE_INSTALL_DIR LIB_INSTALL_DIR)
+
+ write_basic_package_version_file(
+@@ -17,4 +17,4 @@
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/PDALConfig.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/PDALConfigVersion.cmake
+- DESTINATION ${LIB_INSTALL_DIR}/cmake/PDAL)
++ DESTINATION ${PDAL_LIB_INSTALL_DIR}/cmake/PDAL)
diff --git a/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch b/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch
new file mode 100644
index 000000000000..9b712cb0e789
--- /dev/null
+++ b/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch
@@ -0,0 +1,77 @@
+diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
+index 8dd8845f35..c4b7e37543 100644
+--- a/apps/CMakeLists.txt
++++ b/apps/CMakeLists.txt
+@@ -3,7 +3,7 @@
+ #
+ # (based originally on the libLAS files copyright Mateusz Loskot)
+
+-cmake_minimum_required(VERSION 2.8)
++cmake_minimum_required(VERSION 3.5)
+
+ #------------------------------------------------------------------------------
+ # Configure build targets
+diff --git a/cmake/ctest.cmake b/cmake/ctest.cmake
+index a8382aaef5..98035205d1 100644
+--- a/cmake/ctest.cmake
++++ b/cmake/ctest.cmake
+@@ -5,7 +5,7 @@ if(ENABLE_CTEST)
+ if (WITH_TESTS)
+ message(STATUS
+ "Enable CTest to support submissions of results to CDash at http://cdash.org")
+- cmake_minimum_required(VERSION 2.8.0)
++ cmake_minimum_required(VERSION 3.5.0)
+ #
+ # Dashboard has been prepared for experiments
+ # http://my.cdash.org/index.php?project=PDAL
+diff --git a/dimbuilder/CMakeLists.txt b/dimbuilder/CMakeLists.txt
+index 09d334f1f8..9aa9742f63 100644
+--- a/dimbuilder/CMakeLists.txt
++++ b/dimbuilder/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ # The seemingly strange arrangement of this cmake file allows you to build
+ # this application as a standalone.
+ #
+-cmake_minimum_required(VERSION 2.8.6)
++cmake_minimum_required(VERSION 3.5)
+
+ set(MAKE_COLOR_MAKEFILE ON)
+
+diff --git a/plugins/rdb/CMakeLists.txt b/plugins/rdb/CMakeLists.txt
+index 2ec0adcf92..2e8ae422de 100644
+--- a/plugins/rdb/CMakeLists.txt
++++ b/plugins/rdb/CMakeLists.txt
+@@ -1,6 +1,6 @@
+
+ if (STANDALONE)
+-cmake_minimum_required(VERSION 3.1)
++cmake_minimum_required(VERSION 3.5)
+ set(ROOT_DIR "../../${PROJECT_SOURCE_DIR}")
+ include(../../cmake/common.cmake NO_POLICY_SCOPE)
+ include(FeatureSummary)
+diff --git a/tools/lasdump/CMakeLists.txt b/tools/lasdump/CMakeLists.txt
+index 8083a228d8..767d642e76 100644
+--- a/tools/lasdump/CMakeLists.txt
++++ b/tools/lasdump/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ # The seemingly strange arrangement of this cmake file allows you to build
+ # lasdump as a standalone.
+ #
+-cmake_minimum_required(VERSION 2.8.6)
++cmake_minimum_required(VERSION 3.5)
+
+ set(MAKE_COLOR_MAKEFILE ON)
+
+diff --git a/vendor/gtest/CMakeLists.txt b/vendor/gtest/CMakeLists.txt
+index db292946a5..e41e59761e 100644
+--- a/vendor/gtest/CMakeLists.txt
++++ b/vendor/gtest/CMakeLists.txt
+@@ -53,7 +53,7 @@ else()
+ cmake_policy(SET CMP0048 NEW)
+ project(gtest VERSION ${GOOGLETEST_VERSION} LANGUAGES CXX C)
+ endif()
+-cmake_minimum_required(VERSION 2.6.4)
++cmake_minimum_required(VERSION 3.5)
+
+ if (POLICY CMP0063) # Visibility
+ cmake_policy(SET CMP0063 NEW)
diff --git a/sci-libs/pdal/metadata.xml b/sci-libs/pdal/metadata.xml
new file mode 100644
index 000000000000..3be37e190bd4
--- /dev/null
+++ b/sci-libs/pdal/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>thomas.bettler@gmail.com</email>
+ <name>Thomas Bettler</name>
+ </maintainer>
+ <longdescription>
+ PDAL is a C++ library for translating and manipulating point cloud data.
+ It is very much like the GDAL library which handles raster and vector data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">PDAL/PDAL</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/pdal/pdal-2.3.0.ebuild b/sci-libs/pdal/pdal-2.3.0.ebuild
new file mode 100644
index 000000000000..ee1182834970
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/13"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/jsoncpp
+ net-misc/curl
+ sci-libs/gdal
+ sci-libs/libgeotiff
+ sci-geosciences/laszip
+ sys-libs/libunwind
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ ${FILESDIR}/${P}-fix_cmake_install_location.patch
+ ${FILESDIR}/${P}-upgrade_cmake_min.patch
+)
+
+S="${WORKDIR}/PDAL-${PV}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_LAZPERF=OFF
+ -DWITH_LASZIP=ON
+ -DWITH_COMPLETION=ON
+ )
+
+ cmake_src_configure
+}