summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-20 20:47:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-20 21:56:14 +0200
commitc3efa520b5a49e39441282cf1c9677066b7266fc (patch)
tree131816168b8808a18ef65f4e580d51b73ddbae9f
parentkde-plasma/kscreenlocker: 5.20.1 version bump (diff)
downloadgentoo-c3efa520b5a49e39441282cf1c9677066b7266fc.tar.gz
gentoo-c3efa520b5a49e39441282cf1c9677066b7266fc.tar.bz2
gentoo-c3efa520b5a49e39441282cf1c9677066b7266fc.zip
kde-plasma/ksshaskpass: 5.20.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.20.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index b5fd09f0dd1d..d3896fcd3ae0 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.19.5.tar.xz 23572 BLAKE2B c399be04e33a51968c7c3d962039f7aaff176c7a14bb5d8d2da36e999908aba1f3fa07337412390470cab1342a70bd37b2241b750e7bf852980c77810f311873 SHA512 7bd70985cb4a133e49d58b27c9266222913097154b78f60fc55b7ea3e684723b3ae55cdd0b44f58dd7c2cb54cc2f6046907b7881355b437689d9e470c2aafdd4
DIST ksshaskpass-5.20.0.tar.xz 23528 BLAKE2B d1583101a4ad0ba1dd547e38ab053870bcd8cfbb11b6e80b648ec334bfd1fc1dd8f36596f8d5c385225c26c357a5c2b033787a440a98e4f509e6f96c2253761f SHA512 a0e7cad3debde539da8432a84324a42f98206a2d5c22201dca89fe35dda15259eb5aa32ae20ded6c33b7db0b6ba4e4f44fa5b3ea703ecd3e7055e23005dcc563
+DIST ksshaskpass-5.20.1.tar.xz 23520 BLAKE2B 69f8e979c86b81026707ced507a7a77a61eb58e85e8fe619788368d199d5ba33678f2f3e6626f7d989e7f2597e49ca35b822524fb255617bec43a530bb5ea4f9 SHA512 6cdeb41fc0d6b857dc2ce3a35ffa81b9cf054841592f84cd73f3d932055257eee012795e03d2b91cb50ce797e20a2ddbb9698506efd22c5b3d394ba70e2d190a
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.20.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.20.1.ebuild
new file mode 100644
index 000000000000..004a7a7eb33f
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.20.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.74.0
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}