summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-29 19:08:52 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-29 19:11:50 -0500
commitc3f20d644b14ec8ab22fdd03121246ce4ddd6a32 (patch)
treead2069e03b9d70ff7fd547de61178b494ea1005e
parentdev-ml/merlin: drop old 4.3.1-r3 (diff)
downloadgentoo-c3f20d644b14ec8ab22fdd03121246ce4ddd6a32.tar.gz
gentoo-c3f20d644b14ec8ab22fdd03121246ce4ddd6a32.tar.bz2
gentoo-c3f20d644b14ec8ab22fdd03121246ce4ddd6a32.zip
app-portage/iwdevtools: add 0.12.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index bb1a2519c78b..2d6431f6721f 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.0.tar.gz 88411 BLAKE2B 9220d59ee9ec7305925798d8beafec49ef35d8e39a428b62df3b3ed3832da1e42aff5e94ab8c5cfd85272d21cbb13c856408cf665523f8b1de85818ba08aebc4 SHA512 b69face29355df2443e75101b81c477dfdb1f54aad14f0d6275c399bd97cd654c4819f5621177d7ef75ecc4540e923ee5cd42f806240ed346ab469959f6a38d9
+DIST iwdevtools-0.12.1.tar.gz 88857 BLAKE2B 885909b20729279f5d711c65e915078995d0b2d26170f12e6669e499ee42f8a6bd8b5d59930215a3f39f60a1a0b5970f31548d33e059ae314fa1520971bb990a SHA512 3046a661718afbec305dda20990be258a4df981b3a72d49b77384f7a23d8c22e295bb99717c69a4569b6ab3a4195c6dbca0c07b3675bbb78a98aa0a198994988
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild
new file mode 100644
index 000000000000..f618116f15e0
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}