summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-13 06:54:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-13 07:05:36 +0100
commitc4f2e2ef6e18ed19144ee969e83f1a42a7c7901d (patch)
tree7fb383b50733558cfc4acf56b2982f8b37def42a
parentdev-python/Nuitka: Remove old (diff)
downloadgentoo-c4f2e2ef6e18ed19144ee969e83f1a42a7c7901d.tar.gz
gentoo-c4f2e2ef6e18ed19144ee969e83f1a42a7c7901d.tar.bz2
gentoo-c4f2e2ef6e18ed19144ee969e83f1a42a7c7901d.zip
dev-python/Nuitka: Bump to 1.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 512739e36ae5..6285ff1e7932 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-1.4.5.tar.gz 4131887 BLAKE2B b4eaea811a98f1ea5618a477841e2fd2ef41eb4c78635576fadae8a645456f9d47741d1b8c0c102e2774e1802d210785f31a10889d87441693215d84d06cabdd SHA512 fc628be6579f2b290d126fc9f16e16a2fcdd5457a28cb2caa1b2d4e23426933e502a3487485e54cf4e0f67d2d5bca97567d5502070e7ad46a03c513a1f6f9c9f
+DIST Nuitka-1.4.6.tar.gz 4131786 BLAKE2B a72d8b8925dfdd7ca6416912d725cd711c1f8cedabbdc4ea1764645d935529c2b1561c561c6fe8b8cd2babdadd0b6cd3c239ff7e844bd745cebc3b2d94cfbd63 SHA512 883806d787bd35c687bd0771a0f3182d1d157c4c0f403c5b60a03536631823fbdfbaf32c3c29f484aa7de3dacf01056183607109036f60c5602ab08072d8e40d
diff --git a/dev-python/Nuitka/Nuitka-1.4.6.ebuild b/dev-python/Nuitka/Nuitka-1.4.6.ebuild
new file mode 100644
index 000000000000..6f373b0022b9
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.4.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}