summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-21 17:42:30 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:55 +0000
commitc4f69a3ff9f2fbe8879d2e5753f57cbf401c5dbc (patch)
treee7d170a2e4e84f24dbcc43e1d7508bb5cfb407a9
parentdev-haskell/bytestring-builder: keyword 0.10.8.2.0 for ~ppc64 (diff)
downloadgentoo-c4f69a3ff9f2fbe8879d2e5753f57cbf401c5dbc.tar.gz
gentoo-c4f69a3ff9f2fbe8879d2e5753f57cbf401c5dbc.tar.bz2
gentoo-c4f69a3ff9f2fbe8879d2e5753f57cbf401c5dbc.zip
dev-haskell/cabal: add 3.4.1.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/cabal/Manifest1
-rw-r--r--dev-haskell/cabal/cabal-3.4.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/cabal/Manifest b/dev-haskell/cabal/Manifest
index 850a1e04ed8a..7d6fc904f338 100644
--- a/dev-haskell/cabal/Manifest
+++ b/dev-haskell/cabal/Manifest
@@ -1 +1,2 @@
DIST Cabal-3.2.1.0.tar.gz 823331 BLAKE2B 060f4808010f9eefd943312144c75e021bf02083c2a0805128da6c9b93da94ba13fe37cef1fbe27e41fe8a10610e088b923783f4b7bb57150532d3a3ea4a91fc SHA512 279088a2ab9145efc03dbdd10941edcf6034137046ee3b659a8cf0ff075a03e3edff28fd01d432d39701c5a7e05a50b99cf8de95f05d3bd4e75edb3af0e3a598
+DIST Cabal-3.4.1.0.tar.gz 836938 BLAKE2B b185d2beb91a0317b392c6f32ea47a574b8037b23f5131334bca1282359218ab94aa406be737e0fbb15458e7dfa2cba2b22f7776d42c20aeed2b87598cda0e2d SHA512 93233007b70487c76b8ceb9e475ebff0cae4c86a4694820ee505ee83d9049147d60c32c9aea5c4802faf5273adaaae66db299c1ee722aed64c716ac7a3b3aa90
diff --git a/dev-haskell/cabal/cabal-3.4.1.0.ebuild b/dev-haskell/cabal/cabal-3.4.1.0.ebuild
new file mode 100644
index 000000000000..ed14fea82137
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.4.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -bundled-binary-generic
+
+CABAL_PN="Cabal"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # drop tests due to circular deps
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="https://www.haskell.org/cabal/"
+SRC_URI="https://hackage.haskell.org/package/${CABAL_PN}/${CABAL_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+#keep in sync with ghc-9.0.2
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${CABAL_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
+ # That causes module collisions at build:
+ # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
+ # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
+ HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
+ HCFLAGS="${HCFLAGS} -ignore-package=kinds"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bundled-binary-generic
+}
+
+CABAL_CORE_LIB_GHC_PV="PM:9.0.2 PM:9999"