summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-25 21:33:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-25 23:13:28 +0100
commitc6c64364ced3dbe243a86ecbc85bc1c36e65be08 (patch)
tree9b944c77bfc7e27d36e9d8820b08c34cb90272f4
parentmedia-libs/libexif: Add codec project (diff)
downloadgentoo-c6c64364ced3dbe243a86ecbc85bc1c36e65be08.tar.gz
gentoo-c6c64364ced3dbe243a86ecbc85bc1c36e65be08.tar.bz2
gentoo-c6c64364ced3dbe243a86ecbc85bc1c36e65be08.zip
dev-python/pytest: Bump to 6.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-6.2.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 6513ed6979a9..e9e02d072008 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,3 +2,4 @@ DIST pytest-4.6.11.tar.gz 952305 BLAKE2B af07adf5e8fc614b1fdb7b5673fb9c557ff0dd3
DIST pytest-5.4.3.tar.gz 1022353 BLAKE2B 70d4f23cbbfc4c4ce63c512ee0a01556973761a6d3ebb71a6d9ed4fb4a4a21531e1b151ed0e4c5e56e5dd3243a1a272441f17c4c2c4e3b0b19c24654b74e8e52 SHA512 0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e
DIST pytest-6.1.2.tar.gz 1084943 BLAKE2B cbdf29c54118b5daf699f11fb674d37d5972a163a7a53f42f6ddf9224e2d8d9e84b9a88106d5a77e70f470ccbffb15c2cf9a939be69bc0a2cab1fc4c76054562 SHA512 6335e994c5273881c8d1c334fe6bfa9cd0a3e5c251f3d6a9332f7f7c1427e6560ff48d8f235b307ea5eb53491072daf30c41f566bb67b304354fd88d286c61b1
DIST pytest-6.2.1.tar.gz 1102958 BLAKE2B 336757fe911e2bfa1041d7d9c1f83ce66418c55bbe0a1accdac45a36ed5ace972f124bc5f68d2847e3d310bcb2e68a8ced04c74e818ff6f1d43c3ba8b915332d SHA512 abd130212411e0a26265aec922958053e41d05d09d14942b75c1ba81d0ad7c5115d851110a257b32f0b05a2d515961ad068a1fd65f7e275cfe65d16150d008a6
+DIST pytest-6.2.2.tar.gz 1116980 BLAKE2B 7e74050f01fdc4b1ba8a6d703915b0d707305e6e8299917fff8e0cedb873f998c9a904728b77e7234718016ccdac15d491d10411c582d1bfa60d2450a8a2fa7b SHA512 a81def83759c550c169b3db8ed43b4df40433a88acb663e2e9422ef562149ed52041724b7f3cc5d0d6b532f2243a8d9a9614ffbcd87ed571f7fdde7f036c2297
diff --git a/dev-python/pytest/pytest-6.2.2.ebuild b/dev-python/pytest/pytest-6.2.2.ebuild
new file mode 100644
index 000000000000..173f3694ca7a
--- /dev/null
+++ b/dev-python/pytest/pytest-6.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)
+ dev-python/iniconfig[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# flake cause a number of tests to fail
+DEPEND="
+ >=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+python_prepare_all() {
+ # fragile to warnings from other packages (setuptools)
+ # little value for us to run it
+ sed -i -e 's:test_no_warnings:_&:' \
+ testing/test_meta.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX ||
+ die "Tests failed with ${EPYTHON}"
+}