summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-08-19 15:44:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-19 15:45:20 +0300
commitc87110aac367a9d3725fbd234e086bb53b2c5d66 (patch)
tree2e99f27cdc924053028925f7d96037e864083c0a
parentgnome-base/gnome-session: Update gnome-mimeapps.list (diff)
downloadgentoo-c87110aac367a9d3725fbd234e086bb53b2c5d66.tar.gz
gentoo-c87110aac367a9d3725fbd234e086bb53b2c5d66.tar.bz2
gentoo-c87110aac367a9d3725fbd234e086bb53b2c5d66.zip
media-libs/rlottie: bump to 0.2
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-libs/rlottie/Manifest1
-rw-r--r--media-libs/rlottie/rlottie-0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/rlottie/Manifest b/media-libs/rlottie/Manifest
index 585d07e82644..ef50438978ff 100644
--- a/media-libs/rlottie/Manifest
+++ b/media-libs/rlottie/Manifest
@@ -1 +1,2 @@
DIST rlottie-0.1-1.tar.gz 3370181 BLAKE2B 7ba580af961f2af7b92c40b4640f8b515c21a354ef5e639c5f00b0ea26fd3e2929dbf2e926b58d39ad3f48228511ba42a42a24d4b7bb914389a7e43df810d667 SHA512 ab9b913d9e0bc938a878a6847851cd6965dc61efbf8ef71761b83d6ff577479cf0c0b214c36e58ddd6a29927a1954c3d3db9db427779b5a2d472c8962cd45ff1
+DIST rlottie-0.2-1.tar.gz 3516947 BLAKE2B d5f6b643c910e0b831be223be4fcff3d42cde8239b01d413f2805eeccf2665abfbd209ee6877358c2434d3bc82ea7c5b3849f4dca1d0796436e47ffa6bcfed64 SHA512 1f645ae998ddbe83e4911addf28ec24ae3ff33f6439a9fb6c1e56986b46ac17dba155773ab02a59712e781febb31709a99075a3fbcda6136a0cb43dbd7c753de
diff --git a/media-libs/rlottie/rlottie-0.2.ebuild b/media-libs/rlottie/rlottie-0.2.ebuild
new file mode 100644
index 000000000000..c5da30c238e1
--- /dev/null
+++ b/media-libs/rlottie/rlottie-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/v${PV}.tar.gz -> ${P}-1.tar.gz"
+
+LICENSE="BSD FTL JSON MIT"
+SLOT="0/0.2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug examples test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local emesonargs=(
+ -D cache=true
+ -D module=true
+ -D thread=true
+
+ -D cmake=false
+ -D example=false
+
+ $(meson_use debug dumptree)
+ $(meson_use debug log)
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+ eninja test
+}