summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-28 02:54:13 +0000
committerSam James <sam@gentoo.org>2021-03-28 03:00:21 +0000
commitc9106bdfc10e315a72f9e7cf23956add8f2fa2b5 (patch)
tree7f4bf32d62587382bf10d160550869d4ae119506
parentwww-servers/xsp: rename 2014.12-r2014120900 to 3.8_p2014120900 (diff)
downloadgentoo-c9106bdfc10e315a72f9e7cf23956add8f2fa2b5.tar.gz
gentoo-c9106bdfc10e315a72f9e7cf23956add8f2fa2b5.tar.bz2
gentoo-c9106bdfc10e315a72f9e7cf23956add8f2fa2b5.zip
www-servers/xsp: add 4.7.1
Closes: https://bugs.gentoo.org/642942 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-servers/xsp/Manifest1
-rw-r--r--www-servers/xsp/xsp-4.7.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/www-servers/xsp/Manifest b/www-servers/xsp/Manifest
index 1d57520ef23f..b7faea8c1328 100644
--- a/www-servers/xsp/Manifest
+++ b/www-servers/xsp/Manifest
@@ -1 +1,2 @@
DIST xsp-3.8_p2014120900.zip 632555 BLAKE2B e9c63a1e7ae26b45a6d4bec7aca48fc5f9712ffeb17087f6685009abb3feed4395015e8506b3c1333b59658f0334cadb66d181b35e4508bc807bb9680e360196 SHA512 a9d298079cfae4bacac1575f04e58c3106f532c1f283cc243a8a6560561c0a6b535320d1d3e925c7383bd1f7510f31f115d8e85506e31623c175d7f3f606ab91
+DIST xsp-4.7.1.tar.gz 307143 BLAKE2B f8a3a09d644d567728e6462df553ff52fdbd17e974dc25aeebd011e7b6c22ef76be69cc49acfd1cdd9edbd30728ce6b7ef5f33ecda50653db219863b17442b36 SHA512 f106b073bc17ae8fafcffdf2f0db7284f36b62b648fd79321a0de7f5ed15085a9116deccf464e72b3e6f5daf8d65d0a6a3d55c1b275546a4762fa3236bd58e2b
diff --git a/www-servers/xsp/xsp-4.7.1.ebuild b/www-servers/xsp/xsp-4.7.1.ebuild
new file mode 100644
index 000000000000..203ad0669e38
--- /dev/null
+++ b/www-servers/xsp/xsp-4.7.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_DOTNET="net35 net40 net45"
+PATCHDIR="${FILESDIR}/2.2/"
+
+inherit autotools dotnet systemd user
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+SRC_URI="https://github.com/mono/xsp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test developer"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+METAFILETOBUILD=xsp.sln
+
+PATCHES=(
+ "${FILESDIR}/aclocal-fix.patch"
+)
+
+src_prepare() {
+ default
+
+ eaclocal -I build/m4/shamrock -I build/m4/shave ${ACLOCAL_FLAGS}
+ if test -z "${NO_LIBTOOLIZE}" ; then
+ _elibtoolize --force --copy
+ fi
+
+ eautoconf
+ eautomake --gnu --add-missing --force --copy
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--enable-maintainer-mode"
+ )
+
+ use test && myeconfargs+=( "--with_unit_tests" )
+ use doc || myeconfargs+=( "--disable-docs" )
+
+ econf "${myeconfargs[@]}"
+}
+
+#src_compile() {
+# exbuild xsp.sln
+#
+# if use developer ; then
+# exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
+# else
+# exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
+# fi
+#}
+
+pkg_preinst() {
+ enewgroup aspnet
+ enewuser aspnet -1 -1 /tmp aspnet
+
+ # enewuser www-data
+ # www-data - is from debian, i think it's the same as aspnet here
+}
+
+src_install() {
+ mv_command="cp -ar" default
+
+ newinitd "${PATCHDIR}"/xsp.initd xsp
+ newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+ newconfd "${PATCHDIR}"/xsp.confd xsp
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+ insinto /etc/xsp4
+ doins "${FILESDIR}"/systemd/mono.webapp
+ insinto /etc/xsp4/conf.d
+
+ # mono-xsp4.service was original name from
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770458;filename=mono-xsp4.service;att=1;msg=5
+ # I think that using the same commands as in debian
+ # systemctl start mono-xsp4.service
+ # systemctl start mono-xsp4
+ # is better than to have shorter command
+ # systemctl start xsp
+ #
+ # insinto /usr/lib/systemd/system
+ systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
+
+ keepdir /var/run/aspnet
+}