summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-09 07:18:28 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-11 15:20:37 +0200
commitc9728566ed3c5e2f9e4670bc46893e9d43c4d214 (patch)
tree5bb8cb90c3be2a49438ce539d7446678ac82f602
parentmedia-libs/libkate: Enable multilib build (diff)
downloadgentoo-c9728566.tar.gz
gentoo-c9728566.tar.bz2
gentoo-c9728566.zip
media-libs/libtiger: Modernize to EAPI=6
-rw-r--r--media-libs/libtiger/libtiger-0.3.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libtiger/libtiger-0.3.4-r1.ebuild b/media-libs/libtiger/libtiger-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..27909edac9ef
--- /dev/null
+++ b/media-libs/libtiger/libtiger-0.3.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit libtool
+
+DESCRIPTION="A rendering library for Kate streams using Pango and Cairo"
+HOMEPAGE="https://code.google.com/p/libtiger/"
+SRC_URI="https://libtiger.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/pango
+ >=media-libs/libkate-0.2.0
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}