summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 20:50:58 +0100
committerSam James <sam@gentoo.org>2022-06-12 20:51:01 +0100
commitc9a0fbedd1906e5ef876e7c90cab82cc63d07221 (patch)
treefaecbba0defa97ac9fbf36e8cb70aa6cef2c039e
parentapp-admin/terraform: add 1.2.2 (diff)
downloadgentoo-c9a0fbedd1906e5ef876e7c90cab82cc63d07221.tar.gz
gentoo-c9a0fbedd1906e5ef876e7c90cab82cc63d07221.tar.bz2
gentoo-c9a0fbedd1906e5ef876e7c90cab82cc63d07221.zip
x11-wm/blackbox: fix build with GCC 12
Closes: https://bugs.gentoo.org/851603 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-wm/blackbox/blackbox-0.77.ebuild4
-rw-r--r--x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch35
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-wm/blackbox/blackbox-0.77.ebuild b/x11-wm/blackbox/blackbox-0.77.ebuild
index 815969ba46db..32b54c5b3e31 100644
--- a/x11-wm/blackbox/blackbox-0.77.ebuild
+++ b/x11-wm/blackbox/blackbox-0.77.ebuild
@@ -26,6 +26,10 @@ BDEPEND=">=sys-devel/autoconf-2.71
S="${WORKDIR}"/blackboxwm-${PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.77-gcc12-time.patch
+)
+
src_prepare() {
sed -e '/AC_DISABLE_SHARED/d' -i configure.ac || die
default
diff --git a/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch b/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch
new file mode 100644
index 000000000000..196e3878253d
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch
@@ -0,0 +1,35 @@
+https://github.com/bbidulock/blackboxwm/pull/42
+
+From d3481ee7b7d104ef53ead4d35b9a9254c64bb87a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 12 Jun 2022 20:49:09 +0100
+Subject: [PATCH] Fix build with GCC 12 (missing <time.h> include)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes build failure with GCC 12:
+```
+Toolbar.cc: In member function ‘void Toolbar::reconfigure()’:
+Toolbar.cc:260:17: error: ‘time’ was not declared in this scope; did you mean ‘Time’?
+ 260 | time_t ttmp = time(NULL);
+ | ^~~~
+ | Time
+Toolbar.cc:265:21: error: ‘localtime’ was not declared in this scope; did you mean ‘clock_timer’?
+ 265 | struct tm *tt = localtime(&ttmp);
+ | ^~~~~~~~~
+ | clock_timer
+```
+
+Bug: https://bugs.gentoo.org/851603
+--- a/src/Toolbar.cc
++++ b/src/Toolbar.cc
+@@ -38,6 +38,7 @@
+ #include <X11/Xutil.h>
+ #include <sys/time.h>
+ #include <assert.h>
++#include <time.h>
+
+
+ long nextTimeout(int resolution)
+