summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2018-02-23 06:50:40 +0000
committerPatrick Lauer <patrick@gentoo.org>2018-02-23 06:50:40 +0000
commitc9ca0c00b123a6609d9db32df8a15a4c03778e36 (patch)
treed1a3ef3c68f4fbc1e21d1b866e92a794f4870163
parentdev-python/astor: Bump (diff)
downloadgentoo-c9ca0c00.tar.gz
gentoo-c9ca0c00.tar.bz2
gentoo-c9ca0c00.zip
dev-python/rply: Bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/rply/Manifest1
-rw-r--r--dev-python/rply/rply-0.7.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rply/Manifest b/dev-python/rply/Manifest
index b4ab76b49eeb..304529764ebb 100644
--- a/dev-python/rply/Manifest
+++ b/dev-python/rply/Manifest
@@ -1 +1,2 @@
DIST rply-0.7.4.tar.gz 27392 BLAKE2B 3604550646e083bf685a192dcf0dbc80c03cf4b97f6771ed37e228c84909c2518a58bde73ea584085351f1a2b5c865418ae671843087660d48f08e0e44e3ab2c SHA512 e3c3a828eb4b3cb20751ecb2d91efaabddbe3702d52b9adefe1748c07c843da1899e3944bcf0ab79f627ae428b8879cf99739ea7e0c6fd1acffc4ac4dee1b652
+DIST rply-0.7.5.tar.gz 27462 BLAKE2B 0f438e6fd786e7436f135da50fe90208970a0950422bb0d8e26b06cc2def964c0ebd7c3e5e3e282a1d56dbb9e804ac267095dc4da16eb57899f455d66fed2d71 SHA512 ccecc451d9e2e0fdf9df7eaaeabface782d9159cc1caf1feae6e46210f6384aa1a78c15ea3c0e9dcc0bd0d2b28e3b1328c8d37e94a8968b07ef7938e5f5ce201
diff --git a/dev-python/rply/rply-0.7.5.ebuild b/dev-python/rply/rply-0.7.5.ebuild
new file mode 100644
index 000000000000..cc54268d31f2
--- /dev/null
+++ b/dev-python/rply/rply-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="https://github.com/alex/rply"
+SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # https://github.com/alex/rply/issues/26; fail under py[3-4]
+ if python_is_python3; then
+ sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
+ -i tests/test_parsergenerator.py
+ fi
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}