summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-06 10:23:10 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-06 10:23:10 +0200
commitca1e1d408f43ae8dc68e411794123b809b80c5b1 (patch)
treedd8d320ce90a8fc498a1e75d7238516adf9d895a
parentsci-mathematics/rw: update proxy maintainer email (diff)
downloadgentoo-ca1e1d40.tar.gz
gentoo-ca1e1d40.tar.bz2
gentoo-ca1e1d40.zip
media-gfx/gozer: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--media-gfx/gozer/gozer-0.7-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/gozer/gozer-0.7-r3.ebuild b/media-gfx/gozer/gozer-0.7-r3.ebuild
new file mode 100644
index 000000000000..32cb422209cc
--- /dev/null
+++ b/media-gfx/gozer/gozer-0.7-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="tool for rendering arbitrary text as graphics, using ttfs and styles"
+HOMEPAGE="http://www.linuxbrit.co.uk/gozer/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXext
+ >=media-libs/giblib-1.2.1"
+RDEPEND=">=media-libs/giblib-1.2.1
+ media-libs/imlib2"
+
+src_prepare() {
+ default
+ sed -i src/Makefile.am \
+ -e 's|-g -O3|$(CFLAGS)|g' \
+ -e '/LDFLAGS/s|=|+=|g' \
+ || die "sed src/Makefile.am"
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ rm -rf "${D}"/usr/doc || die
+ dodoc TODO README AUTHORS ChangeLog
+}