summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-05-27 13:58:28 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-27 12:09:30 -0400
commitcac0f9671a3124eb616c74abd8f4bea2c26400cb (patch)
treedee9e71b49e7bc36051574a2576085f4bca323a7
parentapp-antivirus/clamav: remove unused patches (diff)
downloadgentoo-cac0f9671a3124eb616c74abd8f4bea2c26400cb.tar.gz
gentoo-cac0f9671a3124eb616c74abd8f4bea2c26400cb.tar.bz2
gentoo-cac0f9671a3124eb616c74abd8f4bea2c26400cb.zip
app-admin/setools: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/8608
-rw-r--r--app-admin/setools/files/setools-3.3.8-no-check-file.patch15
-rw-r--r--app-admin/setools/files/setools-3.3.8-policy-max.patch29
-rw-r--r--app-admin/setools/files/setools-4.0.1-remove-gui.patch17
3 files changed, 0 insertions, 61 deletions
diff --git a/app-admin/setools/files/setools-3.3.8-no-check-file.patch b/app-admin/setools/files/setools-3.3.8-no-check-file.patch
deleted file mode 100644
index 31848e9564b..00000000000
--- a/app-admin/setools/files/setools-3.3.8-no-check-file.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-there's no real need to run AC_CHECK_FILE to see if a file exists. if the
-static link fails later on, then the static lib didn't exist. this also
-breaks cross-compiling.
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -448,8 +448,6 @@
- sepol_srcdir="")
- if test "x${sepol_srcdir}" = "x"; then
- sepol_srcdir=${sepol_devel_libdir}
-- AC_CHECK_FILE([${sepol_srcdir}/libsepol.a],,
-- AC_MSG_ERROR([make sure libsepol-static is installed]))
- else
- AC_MSG_CHECKING([for compatible sepol source tree])
- sepol_version=${sepol_srcdir}/VERSION
diff --git a/app-admin/setools/files/setools-3.3.8-policy-max.patch b/app-admin/setools/files/setools-3.3.8-policy-max.patch
deleted file mode 100644
index cf6917a671d..00000000000
--- a/app-admin/setools/files/setools-3.3.8-policy-max.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-trying to run compiled code fails when cross-compiling.
-probe the value using the preprocessor instead.
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -621,21 +621,8 @@
- sepol_new_errcodes="yes",
- sepol_new_errcodes="no")
-
--AC_RUN_IFELSE(
-- [AC_LANG_SOURCE([
--#include <sepol/policydb/policydb.h>
--#include <stdio.h>
--#include <stdlib.h>
--int main(void) {
-- FILE *f = fopen("conftest.data", "w");
-- if (f != NULL && fprintf(f, "%d", POLICYDB_VERSION_MAX) > 0) {
-- fclose(f);
-- exit(EXIT_SUCCESS);
-- }
-- exit(EXIT_FAILURE);
--}])],
-- sepol_policy_version_max=`cat conftest.data`,
-- AC_MSG_FAILURE([could not determine maximum libsepol policy version]))
-+printf "#include <sepol/policydb/policydb.h>\nPOLICYDB_VERSION_MAX\n" > conftest.c
-+sepol_policy_version_max=`${CPP} -E -P ${CPPFLAGS} conftest.c | tail -1`
- AC_DEFINE_UNQUOTED(SEPOL_POLICY_VERSION_MAX, ${sepol_policy_version_max}, [maximum policy version supported by libsepol])
- CFLAGS="${sepol_save_CFLAGS}"
- CPPFLAGS="${sepol_save_CPPFLAGS}"
diff --git a/app-admin/setools/files/setools-4.0.1-remove-gui.patch b/app-admin/setools/files/setools-4.0.1-remove-gui.patch
deleted file mode 100644
index bb93ff269b8..00000000000
--- a/app-admin/setools/files/setools-4.0.1-remove-gui.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- setools-4.0.1/setup.py.orig 2016-05-22 19:50:02.586000000 +0200
-+++ setools-4.0.1/setup.py 2016-05-22 19:50:56.107000000 +0200
-@@ -163,11 +163,10 @@
- 'build_lex': LexCommand,
- 'build_ext': BuildExtCommand,
- 'build_qhc': QtHelpCommand},
-- packages=['setools', 'setools.diff', 'setools.policyrep', 'setoolsgui', 'setoolsgui.apol'],
-- scripts=['apol', 'sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta'],
-+ packages=['setools', 'setools.diff', 'setools.policyrep'],
-+ scripts=['sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta'],
- data_files=[(join(sys.prefix, 'share/man/man1'), glob.glob("man/*.1") ),
-- (join(sys.prefix, 'share/setools'), glob.glob("data/*.ui") +
-- ["data/perm_map", "qhc/apol.qhc"] )],
-+ (join(sys.prefix, 'share/setools'), ["data/perm_map"] ),],
- ext_modules=ext_py_mods,
- test_suite='tests',
- license='GPLv2+, LGPLv2.1+',